2

I'm new to Ubuntu

I tried this:

sudo add-apt-repository -y ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java9-installer

but it failed:

download failed
Oracle JDK 9 is NOT installed.
dpkg: error processing package oracle-java9-installer (--configure):
subprocess installed post-installation script returned error exit status >1
Errors were encountered while processing:
oracle-java9-installer
E: Sub-process /usr/bin/dpkg returned an error code (1)

Can any one help me?

6
  • If you do it without -y, you will see that webupd8team recommend using java 8 as version 9 has issues. I installed java 8 using this method today & it worked fine (but I don't know how to solve your problem for java 9)
    – Zanna
    Apr 29, 2016 at 16:16
  • thank u @Zanna but it fails either for 8! >HTTP request sent, awaiting response... 403 Forbidden >2016-04-29 22:44:57 ERROR 403: Forbidden. >download failed
    – saeed ngh
    Apr 29, 2016 at 18:15
  • 1
    well, at least you have a different error - that is always progress ;) maybe try purging the ppa and starting again, or like they suggest on the site try downloading the tar then getting the installer
    – Zanna
    Apr 30, 2016 at 7:52
  • Seems the file download.java.net/java/jdk9/archive/114/binaries/… is truncated at 58Mb May 7, 2016 at 21:13
  • Are you still looking for an answer? Seems like this issue was localized...
    – Zanna
    Dec 23, 2016 at 4:28

0

Browse other questions tagged .