When I log in to Skype, the Skype icon doesn't show up on the app indicator (tray/menu bar right side) on Ubuntu 16.04 Xenial.

I've tried the installing the libappindicator1 as suggested here, and it worked for Slack, but not for Skype. I've also tried intalling sni-qt, but it was already installed: sni-qt is already the newest version (0.2.7+15.10.20150729-0ubuntu1)..

How can I fix this?

  • 1
    Install the sni-qt package. – Gunnar Hjalmarsson Apr 29 '16 at 12:59
  • @GunnarHjalmarsson it's already installed :/ – Zoltán Apr 29 '16 at 13:10
up vote 17 down vote accepted

Be sure to have sni-qt installed for i386 :

sudo apt-get install sni-qt:i386

For me on Ubuntu 16.10 installing libappindicator1 and restarting skype solved the problem

sudo apt-get install libappindicator1
  • 2
    Same applies to Skype for linux beta version on fresh install of ubuntu 16.04 , installing libappindicator1 and rebooting machine brings the icon back on the tray. thx @Leszek – bart Mar 31 '17 at 6:38
  • 1
    Perfect solution. I am using 16.04 LTS, latest version at 2015 May and the problem still there. – Andiana May 21 '17 at 3:46
  • This solution works also for Skype version 8.18.0.6 | Calling version 2018.11.01.10. Thank you very much! – pa4080 Apr 4 at 10:16

Note that solutions mentioned here do not work with Ubuntu 17.04 due to a different reason mentioned here:

Also note that sni-qt:i386 package and all qt i386 dependencies are not required for "amd64" version of skypeforlinux. Instead you can use following workaround mentioned in the Unity bug:

$ env XDG_CURRENT_DESKTOP=Unity skypeforlinux

This will launch skypeforlinux with environment variable XDG_CURRENT_DESKTOP set to Unity, the default value of this variable in Ubuntu 17.04 is XDG_CURRENT_DESKTOP=Unity:Unity7 that confuses the electron (which Skype for Linux is build upon).

You can also use this line in the Startup Application entry, but then you should disable "Launch at Login" in Skype and create your own entry.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.