0

I'm pretty sure I did everything - turned off the fast start up, ensured first boot is cd and everything is UEFI. First install I got Ubuntu 14.04 working ok - though I did have two boxes to select o/s, I got error messages and had to select extra things before it would load Ubuntu, selecting windows worked fine. Second install I tried Gnome Ubuntu 16.04 - could never get the option to boot into Ubuntu, windows just loaded. Tried the chroot thing to change the grub/reload the grub, no good. Third Install - back to Ubuntu 14.04 - now that doesn't come up at all - straight to windows. I'm thinking there must be a fundamental thing I'm missing here? New laptop, HP AMD quad core. Any ideas? thanks

4
  • Reading further, I'm thinking when I have attempted to repair or reload the grub2, I may have entered its location incorrectly - I see there is a drive letter and partition number ie sda6. I think 6 is where my Ubuntu install is. Should I have loaded the grub into a special little partition where the UEFI boot loader is? Apr 29, 2016 at 9:32
  • Please run the Boot Info Script. This will generate a file called RESULTS.txt. Post that file to a pastebin site and post the URL to your document here. This will give us more details about your configuration, which is required to base an answer on more than guesswork.
    – Rod Smith
    Apr 30, 2016 at 20:07
  • Thank you for your help. I've done all that here.....paste.ubuntu.com/16168447 May 1, 2016 at 10:57
  • You have to install Windows first then Ubuntu. And make sure both are installed in the same bios mode UEFI or legacy. And no need for manual recovering.. May 1, 2016 at 16:20

2 Answers 2

0

Your Boot Info Script output was generated from a BIOS-mode boot of an emergency disk, but all your OS installations seem to be in EFI mode. This suggests that your Compatibility Support Module (CSM) is active, which can wreak havoc with booting EFI-mode OSes, as described on this page of mine. Thus, I strongly recommend that you disable the CSM. This will require entering your firmware setup utility and finding an option to do this. It may be called "CSM" (or its expansion), "legacy mode boot," or something else; unfortunately, there's no standardization on how this option is named or where it may be located in your firmware setup utility.

Disabling the CSM may not be the end of your problems, though; it could be that your NVRAM settings are corrupted or some other issue may be getting in the way. If you continue to have problems, boot a Linux live disk again, type sudo efibootmgr -v, and edit your question to include the output, adding four spaces to the start of each line. (If the system complains that efibootmgr is not installed, install it. In Ubuntu, you'd do this by typing sudo apt-get install efibootmgr.) There may be redundant entries that you could delete with efibootmgr, or resetting all the firmware options to the defaults may be required -- but the second of these actions will require re-creating an NVRAM boot entry.

0

First make sure if your Windows installation is either Legacy Bios or UEFI.

If it's UEFI, then boot your Ubuntu installation media DVD/USB in UEFI as well.

Continue with installation.

Once the installation completes, log into newly installed Ubuntu, then

sudo os-prober
sudo update-grub
reboot
1
  • 1
    Workaround: I have found that all I need to do is hit f9 on startup each time and after just a few seconds get a basic looking menu with either windoes uefi, ubuntuu uefi or efi. Select ubuntu, job done. May 13, 2016 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.