I am trying to watch HBONow on Ubuntu 16.04LTS on Chrome browser. It is showing the certification video (i.e. PG-13, TV-MA) and then when it tries to load content it's never shows up.

My windows browser is able to load it successfully. What could be the possible solutions?

  • If I wait long enough after the hbo cert video mine says "Can't Play Video: We're having trouble playing this video. Please try again later". Is your error the same?
    – zorkerz
    May 1, 2016 at 19:03
  • No I dont get the same error after waiting long
    – Abhra
    Jun 3, 2016 at 0:08
  • 2
    See possibly here, here, here, here, here, here, here. None of these have worked for me.... Jun 6, 2016 at 22:58

3 Answers 3


Using Pipelight worked beautifully for me. It only runs in Firefox, though.

Installing Pipelight

Open up the old terminal (Ctrl+Alt+T) and copy and paste the following commands. To paste into the terminal do Ctrl+Shift+V.

sudo add-apt-repository ppa:pipelight/stable

After adding the PPA, update the sources with

sudo apt-get update

Next, you have to install Pipelight.

sudo apt-get install --install-recommends pipelight-multi

Then, run the below command to update the plugin.

sudo pipelight-plugin --update

Configuring Pipelight

You may have to remove adobe-flashplugin, but I personally did not need to due to it not being installed.

sudo apt-get remove adobe-flashplugin

Then enable all of the necessary plugins

sudo pipelight-plugin --enable flash

Go one-by-one to ensure you're accepting each's license agreement

sudo pipelight-plugin --enable widevine


sudo pipelight-plugin --enable silverlight

Then update Pipelight to recognize these plugins.

sudo pipelight-plugin --update

Finally, you must add the plugins to Firefox.

sudo pipelight-plugin --create-mozilla-plugins

Testing it out!

If done correctly, Pipelight should have installed an update version of Flash, Silverlight, and Widevine, which it runs through Wine, as can be seen in the Plugins section of the Add-ons Manager.

Firefox plugins with up to date Flash, Silverlight and Widevine

Finally, open up Firefox and test 'er out.

HBO NOW on Ubuntu

Source: https://www.maketecheasier.com/watch-hbo-now-ubuntu/

  • 4
    That didn't work for me : ( Jun 27, 2016 at 4:59
  • 2
    Woohoo! It works. I can't see what I did differently. Thanks so much! Jun 28, 2016 at 0:38
  • 1
    @costa I believe you have to remove the plugins from Firefox too
    – cubecubed
    Aug 11, 2016 at 14:51
  • 1
    When I do this, I am able to see video only when player is fullscreen. Once in fullscreen, none of the video player buttons are accessible, and I must use F-11 to back out. Does anyone else get this behavior?
    – RghtHndSd
    Aug 14, 2016 at 21:02
  • 8
    I think this answer has become obsolete as of Firefox v.52 (around March 2017), due to the termination of NPAPI plugin support support.mozilla.org/en-US/kb/… :( Apr 25, 2017 at 3:24

Pipelight solution does not work at the moment, but Firefox with Flash on PlayOnLinux does.

  1. Install and run PlayOnLinux
sudo apt install playonlinux

  1. Click Install and search for Firefox

enter image description here

  1. Select Flash when prompted
  2. Run Firefox

enter image description here

  1. Go to HBO website and if the videos still do not work, install the Flash they link to.
  • PlayOnLinux is a front-end for Wine. It permits to easily install Windows Games and software on Linux. I have apprehension installing anything related to Windows on my Ubuntu 16.04.1 LTS. I am still clueless how to play videos from Hotstar on Firefox. Mar 12, 2017 at 20:11

I believe you need to install the "hal" package (short for Hardware Abstraction Layer; it allows certain DRM-protected Flash content to verify what hardware device it's being played on, to prevent piracy)

Open a terminal (Alt-Ctrl-T) and add Martin Wimpress's HAL PPA (he's the developer behind Ubuntu MATE):

sudo add-apt-repository ppa:flexiondotorg/hal-flash

Then update your package listing:

sudo apt update

and install hal:

sudo apt install libhal1-flash

Then, to make sure Flash is aware of the changes:

cd ~/.adobe/Flash_Player

rm -rf NativeCache AssetCache APSPrivateData2

Adobe does provide an online test to see if DRM in your player is working. The URL is http://drmtest2.adobe.com:8080/SVP/SampleVideoPlayer_FP.html , and you can test it by entering the following URL into the "video URL" box on that page: http://drmtest2.adobe.com:8080/Content/anonymous.f4v

Please let me know if this was helpful, or if you ran into any issues!

  • drmtest2.adobe.com:8080/Content/anonymous.f4v downloaded a file. Do not know what to do with this. Mar 13, 2017 at 18:37
  • Please read my instructions again, slowly and carefully... If you go to the first URL, then "you can test it by entering the following URL into the 'video URL' box on that page", not by clicking the second URL directly. Mar 13, 2017 at 20:50
  • 1
    didn't work on 17.04. :(
    – JimB
    Jul 18, 2017 at 1:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .