0

I'm using a Lenovo G50-80 and i installed Ubuntu 16.04 LTS last week, but for some reason i can't connect it to wifi without ethernet.

I've tried a handful of different options on this forum, but the option to enable wifi on the top bar still won't appear

Here's my Wireless-info: http://www.mediafire.com/download/3z77zh746ezdvvy/wireless-info.txt

thank you

3
  • i.imgur.com/2xIFqWY.png this is what my connection panel looks like. the option to enable wi-fi is not there. i checked to make sure it's not hard-locked. – DrewTheRedPoochyena May 1 '16 at 23:25
  • This suggests that the correct driver isn't being loaded. Please open a terminal and do: sudo modprobe wl && dmesg | grep wl Please paste the result here and give us the link: paste.ubuntu.com – chili555 May 2 '16 at 14:09
  • i got an error message saying "modprobe: ERROR: could not insert 'wl': Required key not available" – DrewTheRedPoochyena May 3 '16 at 1:19
0

With the ethernet temporarily connected, please open a terminal and do:

sudo apt-get install --reinstall bcmwl-kernel-source

After it completes, detach the ethernet and reboot. If the wireless is not working, please show us:

sudo modprobe wl && dmesg | grep wl
2
  • sorry for the long wait. i did it and it still doesn't work. when i try the modprobe command it still gives me "modprobe: ERROR: could not insert 'wl': Required key not available" – DrewTheRedPoochyena May 17 '16 at 19:49
  • Please see: askubuntu.com/questions/770490/… – chili555 May 22 '16 at 20:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.