I tried sudo apt-get update, but got

E: Could not get lock /var/lib/apt/lists/lock - open (11: Resource temporarily unavailable)
E: Unable to lock directory /var/lib/apt/lists/
E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

Any advice? Let me know if you need any more info.

marked as duplicate by Eric Carvalho, karel, Fabby, Videonauth, Zanna Dec 5 '17 at 11:32

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    you have something already open like synaptic when you tried apt-get update – John Orion Apr 29 '16 at 1:01
  • Right. And btw, how is your title relevant to the content of the question? – Hi-Angel Apr 29 '16 at 3:34

Problem is solved by manually downloading and updating the apt.

Try to use

  1. http://launchpadlibrarian.net/254524267/apt_1.0.10.2ubuntu2_amd64.deb.

If it shows error while updating then run this following deb file first then the previous one.

  1. http://launchpadlibrarian.net/254524270/libapt-pkg4.16_1.0.10.2ubuntu2_amd64.deb

then run those commands:

sudo apt-get update 
do-release-upgrade

Did you disable the security update repository (wily-security) by any chance?

If so enable it again and run: apt-get update && apt-get -y install apt.

After this you should have the newer apt version installed. Hence, you should now be able to run do-release-upgrade without any issues.

  • This answers the title - not the whole question. – UniversallyUniqueID Apr 30 '16 at 19:08

Try to download and install this package manually:

wget http://launchpadlibrarian.net/254524270/libapt-pkg4.16_1.0.10.2ubuntu2_amd64.deb
apt-get install ./libapt-pkg4.16_1.0.10.2ubuntu2_amd64.deb

Not the answer you're looking for? Browse other questions tagged or ask your own question.