4

My keyboard symbols suddenly changed. For example, if I type the backslash key, it gives #, if I use shift + 2, it gives " instead of @. I don't understand what has changed suddenly. Does anybody know how to get this back to normal?

I've tried lots of things: changing the language of the keyboard, restarting the computer, various key combinations, num lock. Nothing seems to work.

Thanks in advance!

  • Check under Settings>>Keyboard. Your layout has been changed to some EU layout. – TheWanderer Apr 28 '16 at 23:24
  • I can't find how to change it back. Should it be changed back to US? – User01 Apr 28 '16 at 23:27
  • There should be an option somewhere there to change the layout back to US. – TheWanderer Apr 28 '16 at 23:28
  • Yeah I tried System settings, text entry and changed it to US there, nothing happened though, not even after restarting. – User01 Apr 28 '16 at 23:30
  • Is there a keyboard button (or any new icon) in the top bar on the desktop? – TheWanderer Apr 28 '16 at 23:32
6

Your keyboard layout was somehow changed, I think to the UK layout.

There should be an icon in the status/menu bar that looks like a keyboard, or is a rectangle with a country code inside. Click that icon and you'll be able to select the US layout.

| improve this answer | |
3

So I faced a similar issue. I was able to fix it in the following way:

  1. Spot the word "ENG" in the task/menu bar at the bottom of the screen.(for me it was right beside where it shows the time and date).
  2. Click on the "ENG" symbol.
  3. From the options that pop up, choose which ever is the alternative to "English (United Kingdom) United Kingdom.Keyboard".

In my case the alternative was "English (India)", clicking on it helped me solve the issue.

| improve this answer | |
0

In Setting section you can find one Language and Region option. there you can Update language in "Input sources" and issue will be resolved.

| improve this answer | |
New contributor
sadaiv panchal is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.