1

I have the new bq Aquaris M10 tablet. The device was recognized by my Linux machine using adb devices. I tried making my filesystem writable using phablet-config writable-image.

Well, this turned out not to be the answer to the problem I was working on. So, I tried to revert back to the stock firmware using:

 ubuntu-device-flash touch --channel=ubuntu-touch/stable/bq-aquaris-pd.en

The flash failed when the device rebooted to Recovery Mode, but the the host machine flashing the image said device not in recovery mode-- or something else similar.

Currrently, the device gets hung on the splash screen on boot up. adb devices does not recognize the device while it is stalled or while in Recovery Mode. I can enter Fastboot Mode, but I cannot do much of anything because, for example, trying to list or erase partitions results in a FAILED (remote: unknown command) error.

I tried loading the device drives in a Windows machine. When I plug in the tablet, I get the little sound for a recognized device. But, when I try to use the MTK Flash Tool to flash the frieza firmware, it does not communicate with the tablet.

Any help is greatly appreciated. Thanks.

0

You can use ubuntu-device-flash with the device in fastboot mode if you pass the --bootstrap flag to ubuntu-device-flash. You will need to use that method if it won't work in recovery.

0

I had a similar problem, and with irc (thanks dobey) and some google food I found this -

first download the recovery image from here: https://wiki.ubuntu.com/Touch/Devices

Then run the command again with the added arg --recovery-image=. The img file is only to allow flashing btw, and doesn't contain the whole OS.

As others said, you also need to boot the device into recovery mode, and then select the option to boot into the bootloader. Then, be sure to append --bootstrap.

So for me, the full command is:

ubuntu-device-flash touch --channel=ubuntu-touch/stable/bq-aquaris-pd.en --recovery-image=~/Downloads/recovery-frieza.img --bootstrap

-1

You need to flash a new recovery.img before.Look here you can found it:https://wiki.ubuntu.com/Touch/Devices

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.