0

I recently installed Ubuntu 16.04 on my desktop PC. My graphics Card is 780GTX, it is recognized and works. I updated to the 361 nvidia binaries driver. But the sound over HDMI doesnt work.

The device is connected and it is shown:

lspci | grep NVIDIA

01:00.0 VGA compatible controller: NVIDIA Corporation GK110 [GeForce GTX 780] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GK110 HDMI Audio (rev a1)

But its not detected as an output device:

aplay -l

Karte 0: PCH [HDA Intel PCH], Gerät 0: ALC887-VD Analog [ALC887-VD Analog]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0

There is only the Mainboard analog output. I googled a lot. First I tried to disable the mainboard output in UEFI, but nothing changes. Then there are no devices listet in aplay -l. It seems that the device is there but ALSA doesnt recognize it.

I tried to update ALSA with: sudo apt-get install oem-audio-hda-daily-dkms

But the last lines are everytime:

 Error configuring:
      oem-audio-hda-daily-dkms
    E: Sub-process /usr/bin/dpkg returned an error code (1)

I am not really a ubuntu GURU and hope you can help me. I hope, if the ALSA drivers are updated it will work, so I hope you can assist me to figure out the error.

Could it be that the daily build of the drivers is broken at the moment for 16.04???

ALSA drivers here: https://launchpad.net/~ubuntu-audio-dev/+archive/ubuntu/alsa-daily/+packages

  • >Could it be that the daily build of the drivers is broken at the moment for 16.04??? -- Yes. You should ask there – Valeriy Solovyov Apr 28 '16 at 21:50
0

it was true... The package build for 16.04 was corrupt. Now, 4 days later, updating the ALSA drivers work! Unfortunately it doesnt resolve my issue with my sound over hdmi with my nvidia gtx780...

Best regards,

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.