26

Ubuntu 16.04 won't power off. When I go to the icon at the top right of the screen and click shutdown, it does not shutdown. I ran shutdown -h now and this is what I got:

tanner@tanner-x151x:~$ shutdown -h now
Failed to set wall message, ignoring: Interactive authentication required.
Failed to power off system via logind: Interactive authentication required.
Failed to start poweroff target: Interactive authentication required.
See system logs and 'systemctl status poweroff.target' for details. 
Failed to open /dev/initctl: Permission denied 
Failed to talk to init daemon. 
tanner@tanner-x151x:~$ sudo shutdown -h now 
[sudo] password for tanner: 
Failed to start poweroff target: Transaction is destructive. 
5ee system logs and 'systemctl status poweroff.target' for details.
tanner@tanner-x151x:~$ sudo halt now
Too many arguments. 
tanner@tanner-x151x:~$ systemctl status poweroff.target
  poweroff.target - Power-off
   Loaded: loaded (/lib/systemd/system/poweroff.target; disabled; vendor preset:
   Active: inactive (dead) 
   Docs: man:systemd.special(7)

I have no idea why this is happening or how to fix this. Any help would be appreciated.

  • 1
    Have you already tried sudo shutdown -P now? I know that is almost the same thing as -h, but with command this I've never got problem. – Danibix Apr 28 '16 at 21:04
  • This "Transaction is destructive" message sounds interesting. What does systemctl status poweroff.target say at this point? – Jos Apr 28 '16 at 21:19
  • @Jos i honestly can not find this file. – Enneptt Apr 28 '16 at 21:32
  • It is a command. Just at the terminal enter systemctl status poweroff.target. – Jos Apr 28 '16 at 21:38
  • i entered it and this is what i got 'tanner@tanner-X751LX:~$ systemctl status poweroff.target ● poweroff.target - Power-Off Loaded: loaded (/lib/systemd/system/poweroff.target; disabled; vendor preset: Active: inactive (dead) Docs: man:systemd.special(7)' – Enneptt Apr 28 '16 at 21:41
6

It's a bit brutal, but you can try:

sudo poweroff -f

Answer credit belongs here: https://askubuntu.com/a/788559/580637

| improve this answer | |
4

The issue should be solved by entering this command to enable the systemd service of "poweroff.target":

systemctl enable poweroff.target
| improve this answer | |
  • 4
    Didn't work for me. :( – Ben Aveling Jan 11 '18 at 2:54
  • 1
    Didn't work for me either – creftos Jan 17 '18 at 1:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.