I have problems with the installation of a Brother Printer Model DCP-375CW. I tried to install it on Ubuntu 16.04 LTS. I downloaded the drivers for linux from the brother website, dcp375cwcupswrapper-1.1.3-1.i386.deb dcp375cwlpr-1.1.3-1.i386.deb

I installed both via GDebi Program. The printer is still not working. It is detected and I can add it but it would not print a test page. The printer is connected via USB.

Does anyone have an idea? Thanks in advance.

PS: I read somewhere that you should change settings at http://localhost:631/printers but for some weird reason I cannot access this.

3 Answers 3


I had problems while installing a Brother HL-L2365DW on Ubuntu 16.04 as a network printer. I've used the official Brother linux-brprinter-installer from their website but the printer was not working. Fortunately the fix was simple.

  1. Go to Printers → Your printer properties
  2. Hit Change on Device URI
  3. Wait 10 seconds until all active printers show up in the list
  4. Choose your printer (LPD network printer, not IPP network printer via DNS-SD)
  5. Hit Apply
  6. In Printer properties change the Device URI host name to the IP address of your printer so it looks something like lpd://
  7. Hit OK and the printer should work

If you want to find the IP address of your printer try doing ping PRINTERHOSTHERE. The printer will not respond to a ping but you will see the IP that your system was trying to ping and that is the IP of your printer.

  • 2
    Welcome to Ask Ubuntu! Very nice first answer. Aug 4, 2016 at 9:51
  • This worked 100% for me with Ubuntu 16.04 and a Brother MFC-L8690CDW printer. Both printer and scanner are working fine now. On an Ubuntu 18.04 system, the official installer by Brother worked right away.
    – SSB
    Apr 3, 2021 at 10:10
  • 2
    DUDE you are a life saver, this was the exact fix I needed. Switching from IPP to LDP and changing to IP address is the key indeed. May 4, 2022 at 18:07
  • I'm surprise no mention of this at all on Brother's official guide. Jun 12, 2022 at 19:30

My FIX...

My Brother DCP-J140W wifi printer+scanner stopped working after a 16.04 install. The Brother Installer complained about some unknown directories, bad file descriptors, etc. I eventually reinstalled CUPS then re-ran the installer. Now printer + scanner working. As follows:

apt-get purge cups   
apt-get install cups
sudo bash linux-brprinter-installer-2.0.0-1 DCP-J140W

Hope this helps.

  • This works perfect for Ubuntu 19.04 and Brother DCP-1622WE
    – Piotr Żak
    Apr 23, 2019 at 19:12
  • This works perfectly for DCP-426W, in Ubuntu 22.04.
    – N. Raj
    Jul 25, 2023 at 8:16

I have a Brother HL-2270DW. After I installed 16.04 The printer would be configured, but would not be available (what ever that means). Then I discovered that the Device URI in System Settings was not the same as what it was with 14.04. I manually changed it to be the same as what it was with 14.04 and the printer works fine now. I can't explain why, but maybe this might give you some ideas.

  • 1
    What was your Device URI?
    – ffonz
    Aug 7, 2022 at 10:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .