How can I make hibernate my desktop in UEFI with Secure boot on.

I used command "sudo pm-hibernate" to make hibernate my desktop but my machine did nothing (my desktop is booted up on UEFI with Secure boot on). But, if I boot my desktop on UEFI with Secure boot off, Hibernation is normal.

Sorry for my English, thanks,


Apparently hibernation is disabled by design with secure boot, since modifying the stored memory content is a potential attack vector.

There seem to exist some kernel patches, which implement signed hibernate images


but I don't know whether there exist any usable packaged kernels for Ubuntu, which include those.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.