3

For some reason, Scroll Lock is not enabled by default. I submit this bug as an enhancement, since as of this moment, I have no idea why Scroll Lock is not already enabled by default. That is the behavior that I expect.

My laptop keyboard does not have a key for Scroll Lock, so I did not notice anything was amiss. It is not until I purchased a keyboard with LED lighting that I noticed that when I pressed the Scroll Lock key, nothing was happening. I was expecting that if I pressed the Scroll Lock key, then the Scroll Lock indicator LED would turn on and the LED in my keyboard would turn on as well, but none of those actions happen. The LED indicator for Caps Lock and Num Lock worked fine, but not for Scroll Lock.

How can I make the Scroll Lock key to work?

3

Temporary Solution

This solution will last as long as the current session. Once you turn off the computer, this modification is erased.

  1. Add scroll lock as a modifying key by commanding xmodmap -e "add mod3 = Scroll_Lock"

Less Temporary Solution

This solution will persist across sessions, but once you upgrade the operating system, this modification is erased.

  1. Open with admin privilege the XKB configuration file located at /usr/share/X11/xkb/symbols/us
  2. Modify it by adding modifier_map Mod3 { Scroll_Lock }; at the end of xkb_symbols "basic"
  3. Reset the XKB layout cache by executing sudo rm -f /var/lib/xkb/* and sudo rm -f /var/lib/lib/xkb/*

Permanent Solution

The scroll lock key needs to be enabled by default. I have added a ticket to X.org's Bugzilla site where you can leave your comment and let them know that this bug affects you.

  • xmodmap no longer works on Ubuntu 18.04 – Planky Apr 4 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.