I want to access a USB memory stick that is plugged into my Huawei B315 LTE router. I have set it up properly as per the web configuration pages on the router but I have no idea how to access it from my xubuntu 15.10 laptop (which is connected to the wifi that is supposedly sharing the USB Stick). I have scoured all the Huawei pages/forums/manual that I could find and I have found no instruction on how to do this.

I have also searched more generally and found either how to consume this from windows or how to consume a windows share from linux neither of which I am trying to do.

I have found various vaguely similar questions, here and elsewhere but they all access a samba share that has a share name on a server with a server name. If my router has a servername or the usb a share name they are well hidden - I have looked in every setting or menu item on the router.

When logged in as admin to the router apart from the usual LTE and WLAN setup pages it has a 'More' Menu. This menu has an item for sharing, clicking on that brings you to the sharing page. from here there are three navigation options Samba, User settings and DLNA.

Under Samba there is a single checkbox to enable Samba sharing and this information:

"Your router supports the Samba server. This allows your computer to access the USB storage device or USB printer connected to the router using the Samba server. To set the Samba account, go to the User Settings page."

The User settings page allows you to create users and give them passwords, and read or read/write access to directories (including all) on the share. I have created a couple of users one with read access and one with read/write.

The DLNA page allows you to enable or disable sharing (I have it enabled) and allows you to set a path (through which setting I have discovered that the usb stick is known to the router as /usb1_1.

I am embarrassed and annoyed that I have spent this much time trying to find a solution to what shouldnt really be a problem. I admit I dont know a lot about linux or ubuntu and I suspect that is why Im having so much trouble with this. Thanks to anyone that can help.

  • If you open a file browser (Nautilus in Ubuntu), and look at the left side panel, there is a "Browse Network" entry there. Click it, and available samba shares should become visible. Apr 28, 2016 at 15:36
  • @mikewhatever I have PCManFM and it has a Network node, I tried what you suggested but I just got a wait cursor for a while and then the address bar showed smb:/// but nothing appeared as content. I will get nautilus and try with that.
    – flurbius
    Apr 28, 2016 at 15:53
  • Alternatively, you could try typing something like this into filebrowser's address bar: smb://router-ip-address. If you don't know the IP, run route -n, and it should show under Gateway. Apr 28, 2016 at 16:01
  • @mikewhatever thanks for putting me on to nautilus I like it better than the other two I have.
    – flurbius
    Apr 28, 2016 at 17:28
  • @mikewhatever browsing the network I got one item called Windows Network. I opened that it eventually then showed me no items, so I entered the routers ip, it hung again for a while and then I got an error dialog "Unable to find the requested file. Please check the spelling and try again. Unhandled error message: File doesn't exist", so I put smb://username@ipadd/ipadd and nearly fell out of my chair when it asked for a password to access share:ipadd in the Workgroup domain. I put in the password but I got "Unhandled error message: Failed to mount Windows share: No such file or directory"
    – flurbius
    Apr 28, 2016 at 17:37

4 Answers 4


After some helpful suggestions (thanks @mikewhatever) and a bit more investigation I've worked it out.

The way to reference this share is in the location bar of the file manager use:

smb://ip address/username/sharename/

The username and sharename you get from the user settings page of the routers web interface when you set up the share - at that stage you must already know the IP address as it's what you use to access the web interface. If the user has access to 'All' then leave out the sharename, otherwise use what the router calls it when you select the users folder.

samba then displays this dialog:

Network Authentication Dialog

I left workgroup in and selected remember until I log out, put in my username and password and then I was able to browse the files.

I had to work most of this out by trial and error. As @mikewhatever suggested I tried using smb://routers-IP-address as the servername, this got me a little further. I then put the username in, received another error, and so on, and after a bit of experimenting I determined what was required. What I've shown here has only been shown with this one router (B315) from Huawei but might be more generally applicable.

I'm guessing the Windows Network and Workgroup stuff is a samba thing, but it does seem odd considering there arent any windows computers on the network.

What I'd like to know now is why isn't this info more readily available?

  • Usually the exact steps are provided in the router's manual. The procedure would likely be for Windows, so it would look something like this: \\server-name\share-name. Looks like Huawei forgot to put it in their manual. Apr 28, 2016 at 20:02

Please check whether the DLNA setting is enable or not. If you want to access the USB you need enable the DLNA setting. This setting is in share options on the router web page.

  • 1
    could you give a bit more detail on how to do this?
    – Zanna
    Mar 23, 2017 at 8:50

To access the files in windows press Windows Key + R. This will bring a Run dialog box. Once the Run dialog box appears, type in the ip address of your router like this \\ and hit Enter. If you're prompted with a credentials dialog box, key in your user's credentials, if not prompted, the shared folder will definitely appear. If you want you can map the shared folder and give it youre desired name. Please let me know once you try.


Well I have an Archer VR900 router, attached to it is a 500G USB SSD. Using OpenSuse / KDE I opened up Dolphin file browser and typed in as the folder location (that is the IP address of the router, it maybe

Dolphin displays the USB attached drive as volume(sda1) in the folder list and I just navigated from there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.