This problem was present with 14.10, 15.04, and 15.10, I simply haven't been able to fix it.

I'm using Chrome 50 as a browser. I've changed the hosts: files dns line in nsswitch.conf file, and tried other suggested fixes.

My friend with MacOS does not experience the same slowness.

Here is some Laptop info. I'm on a Dell XPS 13 with i3 processor, and I can gladly show more if needed.

02:00.0 Network controller [0280]: Intel Corporation Wireless 7260 [8086:08b1] (rev 6b)
    Subsystem: Intel Corporation Dual Band Wireless-AC 7260 [8086:c470]
    Kernel driver in use: iwlwifi
    Kernel modules: iwlwifi

Thanks in advance!

Edit: some output of sudo lshw

    description: Wireless interface
    product: Wireless 7260
    vendor: Intel Corporation
    physical id: 0
    bus info: pci@0000:02:00.0
    logical name: wlan0
    version: 6b
    serial: 5c:51:4f:7c:2a:db
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=iwlwifi driverversion=4.4.0-21-generic firmware=16.242414.0 ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
    resources: irq:46 memory:f0400000-f0401fff
  • How do you measure speed? – Pilot6 Apr 28 '16 at 15:24
  • Well occasionally it fails to connect all together. Other times loading google.com takes over 1 minute. And some sites for measuring download speed fail to even complete the download (simply takes too long). The speed also changes over time. I am able to post this now, for example. – forallepsilon Apr 28 '16 at 15:25
  • If you are connected via WiFi maybe sometimes there are a lot ot interference and that is why you can't navigate. Are you near the Access Point? – migrc Apr 28 '16 at 15:59
  • Not particularly, but my friend with the MacBook is right next to me, and his connection is much faster. Would interference affect different hardware differently? – forallepsilon Apr 28 '16 at 16:01
  • No, it shoudn't. Maybe is a drivers problem. Did you try with other OS? – migrc Apr 29 '16 at 7:49

I had a similar issue with my system preferring IPv6 over IPv4. To change to preferring IPv4 over IPv6.

Open a terminal

sudo nano /etc/gai.conf

Locate #precedence ::ffff:0:0/96 100 and and remove the #.

You may have to reboot. Should notice the difference quickly

  • @FromReview It works for me! :-) – Malabarba Jul 15 '16 at 22:01
  • Very strange. I have the a Network controller: Intel Corporation Wireless 7260 (rev 73) on my MSI motherboard. Makes very little since that the wireless would pick up speed when forced to run in IPv4. I don't have the same issue on a laptop. Is this a device driver or firmware issue? – mjwittering Aug 11 '16 at 19:04
  • That fixed it, but why does it work? – Joald Mar 4 '18 at 12:10
  • Is it supposed to be precedence ::ffff :0:0/96 100 or 10? I had 10 by default – 3nuc Aug 10 '19 at 14:53
  • @ArturTagisow There's 10 and 100 both. If you scroll down a bit you will find 100. – Hackinet Feb 27 '20 at 4:37

Update: In my case, my answer is not valid. The issue later returned. Dell later admitted an ongoing issue with the hardware running on Ubuntu and sent a tech to install a different Wireless card.

This resolved wireless issues for me (commands were provided by Dell Support):

sudo mkdir -p /lib/firmware/ath10k/QCA6174/hw3.0/
sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/board.bin https://github.com/FireWalkerX/ath10k-firmware/blob/7e56cbb94182a2fdab110cf5bfeded8fd1d44d30/QCA6174/hw3.0/board-2.bin?raw=true
sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/firmware-4.bin https://github.com/FireWalkerX/ath10k-firmware/blob/7e56cbb94182a2fdab110cf5bfeded8fd1d44d30/QCA6174/hw3.0/firmware-4.bin_WLAN.RM.2.0-00180-QCARMSWPZ-1?raw=true
sudo chmod +x /lib/firmware/ath10k/QCA6174/hw3.0/*

Edit: For me, the issue was that the driver was looking for files that didn't exist. Presumably caused by running Ubuntu updates after setting up the machine.

  • How did you end up concluding the driver was looking for files that did not exist? Did you check some logs or something? I tried your solution and it did not work for me anyway... – Augustin Riedinger Jun 7 '17 at 17:11
  • 1
    Please see my updated answer. – TylersSN Jun 7 '17 at 17:40

I had similar problem. My solution was :

  • force disable the 802.11n protocol.

1/Open the terminal and use the following command:

sudo rmmod iwlwif
sudo modprobe iwlwifi 11n_disable=1

2/Restart computer.

3/If you have faster WIFI save changes permament by using commands:

sudo su
echo "options iwlwifi 11n_disable=1" >> /etc/modprobe.d/iwlwifi.conf

Not the answer you're looking for? Browse other questions tagged or ask your own question.