2

So, quick background, on Kubuntu and have massive screen tearing issues. I have never had these problems on any other Linux Distros. Videos look really choppy, overall it's not a good experience. I have recently switched over from Windows, and don't know how to update/install drivers on Ubuntu. I just know I have Intel... Sorry if I am being vague, but that's all I got.

  • Post the output of lspci -k | grep -EA2 'VGA|3D' please. – Zzzach... May 11 '16 at 4:08
1

I also experienced video tearing with Kubuntu 16.04 on my Intel i7-2600K Sandybridge processor with integrated Intel HD 3000 Graphics.

SOLUTION A: Best solution

  1. Start K -> Settings -> System Settings
  2. Under Hardware section double-click Display and Monitor
  3. Choose Compositor on LHS and ensure:

    Enable compositor on startup:  Checked   # was enabled by default
    Tearing prevention ("vsync"):  Full screen repaints   # was Automatic
    

    Note: Ignore message "Full screen repaints" can cause performance problems.

    Do not use Re-use screen content on Intel Graphics!

  4. Click Apply

This completely fixed the problem for me. There was no video tearing in full screen or in a window, and there was no artifacting.

See Bug 321589 - Automatic VSync strategy causes tearing

SOLUTION B:

Edit /etc/environment and add the following lines:

__GL_YIELD="USLEEP"
KWIN_USE_BUFFER_AGE=0

Save the file and reboot.

This fixed the problem for me with full screen videos. There is; however, occasional tearing with videos in a window. There was no artifacting with these settings.

BACKGROUND:

I discovered the three variables to try, which were listed as working for NVidia graphics, at the following link: Screen Tearing After Kubuntu Upgrade 15.10 -> 16.04

__GL_YIELD="USLEEP"
KWIN_TRIPLE_BUFFER=0
KWIN_USE_BUFFER_AGE=0

The above three lines did prevent video tearing, but I experienced some artifacting with some non-video playing activities, such as editing a file with emacs. Hence I experimented some more and found a better compromise.

For a description of these KDE variables see KWin/Environment Variables.

Later on I discovered the Full screen repaints setting which completely resolved all issues for me.

1

In Kubuntu 16.04 I solved it by changing the Rendering backend

Go to System Settings > Display and Monitor > Compositor(in the side bar) > change rendering engine to OpenGL 3.1

  • This fixed it for me too (ubuntu 18.10) – Oenotria Feb 23 '19 at 20:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.