I'm trying to use mt SONY MDR-XB950BT headphones on Ubuntu 16.04 but not having any luck. I've managed to get them connected but it doesn't seem like I can actually listen to music/videos out of them. I tried setting the audio output to the headphones, but sound keeps coming out of the speakers instead. I also installed Pulse Audio Volume Control, but that doesn't seem to make a difference. I briefly managed to get it so that the test sound would play through the headphones, but when I tried to watch an online video, the video wouldn't even play until I changed the sound output device.

Does anyone have any advice/experience with this kind of thing? Any help would be greatly appreciated.

  • are you using the unity desktop environment? Apr 28, 2016 at 11:48
  • Yeah, I'm using unity
    – Chris
    Apr 28, 2016 at 14:30
  • did you check if the bluetooth connection is properly set in the "system settings" menu? there is a bluetooth menu there, if the device is properly connected you should see it bold. The next thing I would check is the sound output setting, in the same "system settings" menu. There you should be able to select your headphones as main audio output. Apr 30, 2016 at 7:10
  • 1
    I have the same issue (same headphones too). The bluetooth icon shows connected and in sound settings I have made sure it is the selected device. Other bluetooth headphones work (but sporadically).
    – user141510
    May 31, 2016 at 22:11
  • For issues with Bose QC35 headphones, check out askubuntu.com/questions/833322/…
    – Ned
    Jul 30, 2017 at 18:34

9 Answers 9


I solved this problem by installing blueman.

To install blueman, open a terminal and type sudo apt-get install blueman. Once it's installed, you can run it by typing blueman or you can search for "bluetooth manager" in the Applications menu. Once blueman is running, you can lock it to the launcher.

Now, inside the blueman application, Right-Click on the headphones icon and select 'audio profile' -> 'High Fidelity Playback'.

There are other profiles available as well, but this is the one that works for me.

  • Unity is one thing. Mate is another. we get vlc for default too. That is why we love Mate. It works. Jun 2, 2016 at 22:34
  • 6
    blueman IS NOT already installed on 16.04. Jan 17, 2017 at 12:39
  • 7
    Blueman worked for me too, but I had to right click on the headset (an LG HBS900) and Connect to 'Audio Sink' first, then fumble around with the Sound settings... yuck. Far from a seamless experience. And I still hear interruptions in playback, even though I'm less than 1 meter from my laptop. Mar 3, 2017 at 9:56
  • Alternatively, you can do a similar thing using pavucontrol if blueman doesn't work for you (it didn't for me). Also note I had to select headset, not high fidelity for mine to work.
    – balloons
    Jul 12, 2017 at 20:38
  • Just a quick note to say that I believe the issue here seems to be related to @DanDascalescu 's comment - I was able to connect without blueman, but the sound seemed to be "off". With blueman I was able to change the audio profile to A2DP Sink
    – mmalmeida
    Jul 20, 2017 at 16:34

I recently upgraded to ubuntu 16.04 and got the same bug trying to connect my UE Boom 2. Some extensive googling shows that this is an ongoing issue with 16.04 since it was released in April 2016.

Nevertheless, I came across this discussion and managed to solve the issue with suggestions from Emmentaler and Brian Peacock.

Firstly with my UE Boom 2 connected, I went into "Sound Settings" and made sure the output "mode" was set to "Headset Head Unit (HSP/HFP)", NOT "High Fidelity Playback (A2DP Sink)". Making sure it was in the low quality output is the only way I can ensure a successful connection. Then I installed blueman sudo apt-get install blueman and then rebooted.

From here, I clicked on the original bluetooth icon in the menubar, went to "UE Boom 2" and made sure the "connection" was set to OFF.

After that, I clicked on the new bluetooth icon in the menubar provided by blueman and selected "devices". The "UE Boom 2" appears in the window when it's discoverable. Now click "Setup..." at the top of the window. Given the choice of connection, under "Connect to:", I selected "Audio Sink". This took a couple of tries, but it worked eventually.

Once successfully connected, close the setup window and go back to the sound settings. You should now be able to switch the output mode to "High Fidelity Playback (A2DP Sink)" without losing audio. This is now the process I use to start up my UE Boom 2 each time I need to use it.

Your mileage may vary, but I hope this works for anyone who needs it. This bug has been driving me crazy all day.

TLDR: Connect using regular bluetooth, set connection to "On", set the output to "HSP/HSF" in sound settings (make sure that works), set connection to "Off". Then set up the device using blueman, connect it as an "Audio Sink". Now back into sound settings and change the output to "A2DP".

  • 1
    The only answer that worked for me !
    – Korri
    Oct 25, 2016 at 13:54
  • I confirm: this works for my Plantronics Backbeat Pro.
    – jplandrain
    Dec 26, 2016 at 15:40
  • This solution worked for me on my Jabra Move Wireless... unfortunately. Ridiculous. At least these headsets support wired playback Jan 30, 2017 at 11:47
  • 1
    For some reason, I periodically am unable to connect to my headset as "High Fidelity Playback (A2DP Sink)" , and only can connect as low quality "HSP/HSF", and I have to delete and again setup as new device ("headset", not "audio sink"; also, using blueman), and it works again. Frustrating, so I have to keep earbuds handy for when bluetooth fails.
    – michael
    Jul 27, 2017 at 7:02
  • 1
    This is the only thing that works for me, so I wrote a script that does all of these steps. gist.github.com/ConnorWGarvey/48484f93052ebf41211835ed2110bced Jan 31, 2018 at 21:04

I am using SONY MDR-XZ770BN and I had no problems with Ubuntu 14.04 using the default bluetooth. After installing 16.04 the High Fidelity Playback A2DP Sink was not working. Problem was solved after installing the Blueman manager and selecting the Audio Sink option. Still experiencing some minor issues as sometimes I have to switch off and on the bluetooth before success but it is doing well overall. Try it and maybe it works also for you :)

P.S. After looking up for some answers on the web it seems that bluetooth issues are always present in Ubuntu. It would be great if it is finally fixed :D

  • 44
    +1 After looking up for some answers on the web it seems that bluetooth issues are always present in Ubuntu May 16, 2016 at 17:21
  • 1
    I have Kicksound Arcade Bluetooth headphones which worked quite reliably until my 15.10 to 16.04 upgrade, when I started to need some amount of restarting services etc. to get them to work. Bluetooth sound works flawlessly after installing Blueman. Thanks a lot!
    – Pabru
    Jun 26, 2016 at 12:02
  • but after disabling of handfone MDR-XZ770BN (by button) and enebling, bluetooth connection don't recover automatically =(
    – demon101
    Jan 14, 2017 at 16:39

I know it's a late answer, and the answers are great, but just to clarify for people who are a little confused about the answers like I was, here's a step by step guide:

  1. install blueman from official repositories:
    sudo apt-get install blueman
  2. open the bluetooth manager, from applications menu or the tray icon.enter image description here
  3. Select your device, and follow the wizard to connect it (It's really easy, and you can alternatively do this step using your desktop manager's built-in bluetooth settings) blueman after connecting the device

  4. After you connected your bluetooth device, right click on its name in the blueman and select Audio Profiles > High Fidelity Playback (A2DP Sink) like this : selecting audio profile

hope this helps.

  • great late answer indeed Dec 24, 2016 at 18:41
  • 1
    In case it helps others: After completing the process described in this answer, I had to also go into Ubuntu's sound settings and then click on my bluetooth headphones (in the "output" device list) to divert the sound to them.
    – user606179
    May 24, 2019 at 15:21
  • Will this fix the microphone problem? Airpods mic is basically not working on Ubuntu
    – dcalap
    May 25, 2020 at 7:24
  • @dcalap I don't think I have ever managed to get Bluetooth input working on any of my Linux laptops. Not sure if it's a bluez issue or ALSA. I've always used the standard input so I've never looked into it lol May 26, 2020 at 19:08

I had the same issue with my Phillips BT Headphones on Ubuntu-MATE 16.04.

Here's how I solved it after the headphones had been discovered/paired etc.

  • Started playing some audio

  • Blueman: Connected headphones via the 'Audio Sink' option, setting 'Audio Profile' to 'High Fidelity Playback'. Marked the headphones as 'Trusted' in the 'Device' menu (or by right-click context option).

  • Ubuntu 'Sound Preferences': In the 'Hardware' tab turned off 'Built-in Audio' and set the headphones (same ID as appears in Blueman) to HSP/HFP. In the 'Output' tab selected the headphones (again, same ID as appears in Blueman).

A bit fiddly, but did the job. Turning the 'Built-in Audio' on again once the headphones were connected had no adverse effect on playback, and audio played as normal after the headphones were disconnected. :)


Go to ***Sound Settings*** and set Mode: to "High Fidelity Playback (A2DP Sink)" from "Headset Head Unit (HSP/HFP)"

Go to Sound Settings and set Mode: to "High Fidelity Playback (A2DP Sink)" from "Headset Head Unit (HSP/HFP)"

Problem is the sound quality and Bluetooth version support.


Here is what worked for me:

  1. Installed Blueman

And for every time I want to use it:

  1. Connect to headphones in Blueman (right click and click either headset or hands free)
  2. Right click device in Blueman --> Audio Profile --> Off
  3. Disconnect in Blueman (right click and click either headset or hands free)
  4. Connect again (see 1)
  5. Right click device in Blueman --> Audio Profile --> High Fidelity Playback - A2DP Sink)

This has been the only way for it to work 100% of the time.


I was on ubuntu 15.04. While on it, i was already having the problem with my Sony MDR-ZX550BN. The problem was sometimes, ubuntu refused to play sound through AD2P. What i ended up usually doing, was un-pairing the device (remove it from the bluetooth devices list), then repairing it. It was working.

Then i upgraded to Xenial Xerus (16.04). I still had the same problem but more frequently. I installed Blueman from the ubuntu store, and the problem disappeared.

TL;DR: Install Blueman with the device already paired.


Also have Sony MDR-XB950BT. Kubuntu 18.04 LTS. Open System settings > find "Configure the Audio Volume" > select "Advanced" tab. Find "Built-in Audio" > press "Profile:" combobox and select Digital Stereo (HDMI) Output. Worked for me.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .