I'm trying to use mt SONY MDR-XB950BT headphones on Ubuntu 16.04 but not having any luck. I've managed to get them connected but it doesn't seem like I can actually listen to music/videos out of them. I tried setting the audio output to the headphones, but sound keeps coming out of the speakers instead. I also installed Pulse Audio Volume Control, but that doesn't seem to make a difference. I briefly managed to get it so that the test sound would play through the headphones, but when I tried to watch an online video, the video wouldn't even play until I changed the sound output device.

Does anyone have any advice/experience with this kind of thing? Any help would be greatly appreciated.

  • are you using the unity desktop environment? – Andrea Borga Apr 28 '16 at 11:48
  • Yeah, I'm using unity – Chris Apr 28 '16 at 14:30
  • did you check if the bluetooth connection is properly set in the "system settings" menu? there is a bluetooth menu there, if the device is properly connected you should see it bold. The next thing I would check is the sound output setting, in the same "system settings" menu. There you should be able to select your headphones as main audio output. – Andrea Borga Apr 30 '16 at 7:10
  • I have the same issue (same headphones too). The bluetooth icon shows connected and in sound settings I have made sure it is the selected device. Other bluetooth headphones work (but sporadically). – user141510 May 31 '16 at 22:11
  • For issues with Bose QC35 headphones, check out askubuntu.com/questions/833322/… – Ned Jul 30 '17 at 18:34

I solved this problem by installing blueman

In blueman right click on the headphone and select 'audio profile' -> 'High Fidelity Playback'

There may be better profiles but this works for me.

I ran blueman from the terminal with sudo apt-get install blueman and then ran blueman and locked it to launcher.

  • 2
    No it is not, mate. At least not with unity. – user141510 Jun 1 '16 at 22:06
  • Unity is one thing. Mate is another. we get vlc for default too. That is why we love Mate. It works. – Bhikkhu Subhuti Jun 2 '16 at 22:34
  • 3
    blueman IS NOT already installed on 16.04. – Gilberto Albino Jan 17 '17 at 12:39
  • 5
    Blueman worked for me too, but I had to right click on the headset (an LG HBS900) and Connect to 'Audio Sink' first, then fumble around with the Sound settings... yuck. Far from a seamless experience. And I still hear interruptions in playback, even though I'm less than 1 meter from my laptop. – Dan Dascalescu Mar 3 '17 at 9:56
  • Alternatively, you can do a similar thing using pavucontrol if blueman doesn't work for you (it didn't for me). Also note I had to select headset, not high fidelity for mine to work. – balloons Jul 12 '17 at 20:38

I recently upgraded to ubuntu 16.04 and got the same bug trying to connect my UE Boom 2. Some extensive googling shows that this is an ongoing issue with 16.04 since it was released in April 2016.

Nevertheless, I came across this discussion and managed to solve the issue with suggestions from Emmentaler and Brian Peacock.

Firstly with my UE Boom 2 connected, I went into "Sound Settings" and made sure the output "mode" was set to "Headset Head Unit (HSP/HFP)", NOT "High Fidelity Playback (A2DP Sink)". Making sure it was in the low quality output is the only way I can ensure a successful connection. Then I installed blueman sudo apt-get install blueman and then rebooted.

From here, I clicked on the original bluetooth icon in the menubar, went to "UE Boom 2" and made sure the "connection" was set to OFF.

After that, I clicked on the new bluetooth icon in the menubar provided by blueman and selected "devices". The "UE Boom 2" appears in the window when it's discoverable. Now click "Setup..." at the top of the window. Given the choice of connection, under "Connect to:", I selected "Audio Sink". This took a couple of tries, but it worked eventually.

Once successfully connected, close the setup window and go back to the sound settings. You should now be able to switch the output mode to "High Fidelity Playback (A2DP Sink)" without losing audio. This is now the process I use to start up my UE Boom 2 each time I need to use it.

Your mileage may vary, but I hope this works for anyone who needs it. This bug has been driving me crazy all day.

TLDR: Connect using regular bluetooth, set connection to "On", set the output to "HSP/HSF" in sound settings (make sure that works), set connection to "Off". Then set up the device using blueman, connect it as an "Audio Sink". Now back into sound settings and change the output to "A2DP".

  • 1
    The only answer that worked for me ! – Korri Oct 25 '16 at 13:54
  • I confirm: this works for my Plantronics Backbeat Pro. – jplandrain Dec 26 '16 at 15:40
  • This solution worked for me on my Jabra Move Wireless... unfortunately. Ridiculous. At least these headsets support wired playback – Asfand Qazi Jan 30 '17 at 11:47
  • 1
    For some reason, I periodically am unable to connect to my headset as "High Fidelity Playback (A2DP Sink)" , and only can connect as low quality "HSP/HSF", and I have to delete and again setup as new device ("headset", not "audio sink"; also, using blueman), and it works again. Frustrating, so I have to keep earbuds handy for when bluetooth fails. – michael Jul 27 '17 at 7:02
  • 1
    This is the only thing that works for me, so I wrote a script that does all of these steps. gist.github.com/ConnorWGarvey/48484f93052ebf41211835ed2110bced – ConnorWGarvey Jan 31 at 21:04

I am using SONY MDR-XZ770BN and I had no problems with Ubuntu 14.04 using the default bluetooth. After installing 16.04 the High Fidelity Playback A2DP Sink was not working. Problem was solved after installing the Blueman manager and selecting the Audio Sink option. Still experiencing some minor issues as sometimes I have to switch off and on the bluetooth before success but it is doing well overall. Try it and maybe it works also for you :)

P.S. After looking up for some answers on the web it seems that bluetooth issues are always present in Ubuntu. It would be great if it is finally fixed :D

  • 28
    +1 After looking up for some answers on the web it seems that bluetooth issues are always present in Ubuntu – RepeatUntil May 16 '16 at 17:21
  • 1
    I have Kicksound Arcade Bluetooth headphones which worked quite reliably until my 15.10 to 16.04 upgrade, when I started to need some amount of restarting services etc. to get them to work. Bluetooth sound works flawlessly after installing Blueman. Thanks a lot! – Pabru Jun 26 '16 at 12:02
  • but after disabling of handfone MDR-XZ770BN (by button) and enebling, bluetooth connection don't recover automatically =( – demon101 Jan 14 '17 at 16:39

I know it's a late answer, and the answers are great, but just to clarify for people who are a little confused about the answers like I was, here's a step by step guide:

  1. install blueman from official repositories:
    sudo apt-get install blueman
  2. open the bluetooth manager, from applications menu or the tray icon.enter image description here
  3. Select your device, and follow the wizard to connect it (It's really easy, and you can alternatively do this step using your desktop manager's built-in bluetooth settings) blueman after connecting the device

  4. After you connected your bluetooth device, right click on its name in the blueman and select Audio Profiles > High Fidelity Playback (A2DP Sink) like this : selecting audio profile

hope this helps.

I had the same issue with my Phillips BT Headphones on Ubuntu-MATE 16.04.

Here's how I solved it after the headphones had been discovered/paired etc.

  • Started playing some audio

  • Blueman: Connected headphones via the 'Audio Sink' option, setting 'Audio Profile' to 'High Fidelity Playback'. Marked the headphones as 'Trusted' in the 'Device' menu (or by right-click context option).

  • Ubuntu 'Sound Preferences': In the 'Hardware' tab turned off 'Built-in Audio' and set the headphones (same ID as appears in Blueman) to HSP/HFP. In the 'Output' tab selected the headphones (again, same ID as appears in Blueman).

A bit fiddly, but did the job. Turning the 'Built-in Audio' on again once the headphones were connected had no adverse effect on playback, and audio played as normal after the headphones were disconnected. :)

Go to ***Sound Settings*** and set Mode: to "High Fidelity Playback (A2DP Sink)" from "Headset Head Unit (HSP/HFP)"

Go to Sound Settings and set Mode: to "High Fidelity Playback (A2DP Sink)" from "Headset Head Unit (HSP/HFP)"

Problem is the sound quality and Bluetooth version support.

I was on ubuntu 15.04. While on it, i was already having the problem with my Sony MDR-ZX550BN. The problem was sometimes, ubuntu refused to play sound through AD2P. What i ended up usually doing, was un-pairing the device (remove it from the bluetooth devices list), then repairing it. It was working.

Then i upgraded to Xenial Xerus (16.04). I still had the same problem but more frequently. I installed Blueman from the ubuntu store, and the problem disappeared.

TL;DR: Install Blueman with the device already paired.

Here is what worked for me:

  1. Installed Blueman

And for every time I want to use it:

  1. Connect to headphones in Blueman (right click and click either headset or hands free)
  2. Right click device in Blueman --> Audio Profile --> Off
  3. Disconnect in Blueman (right click and click either headset or hands free)
  4. Connect again (see 1)
  5. Right click device in Blueman --> Audio Profile --> High Fidelity Playback - A2DP Sink)

This has been the only way for it to work 100% of the time.

protected by Community Nov 6 '16 at 14:20

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.