0

I am running Ubuntu server 16.04 LTS guest OS in Virtualbox 5.0.8 under Ubuntu MATE 15.10 LTS host OS. I am setting up a little development LAMP server and I am editing apache configuration files. I used nano to edit and everything seemed to work with the keyboard. However trying to save and exit the file doesn't seem to be working.

All of nano's commands seem to use the format of ctrl + . NOTE: The HOST Control button is "right ctrl" and I am trying to use the "left ctrl" for commands. ctrl + x - is the command to exit the file. however pushing ctrl + x (in combination, that is holding left ctrl and pressing the 'x'button) only outputs the letter x to the file as if i was just pressing it by itself.

My main issue now is that I can't even exit the file to try it with vi instead (since it doesn't use any ctrl + for simple editing ( ':wq' will work).

Any help with this issue would be very much appreciated. Thanks.

  • Also see askubuntu.com/questions/36292/… – Takkat Apr 28 '16 at 14:26
  • Sorry about that I tried a search but my qeury must not have been very clear. Also there is alot of useful info on that page however none of them is the solution i found. Holding the shift key activates the left ctrl key, haven't tried it with any shift+ctrl commands (which I'm sure will lead to a conflict). So remapping the key is probably a better permanent solution however, in my situation I had already done alot of editing and needed to save and exit rather than restart the VM and lose all changes. This solution works for that situation. – Sal Bruno Apr 28 '16 at 14:54
0

Well Some playing around with different combinations of keys let me use "Left-SHIFT + Left-CTRL + x" seemed to work just like pressing Left-CTRL. So my solution was add the shift key to the combination.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.