6

This is something that was answered in the past already for previous versions, there are bug reports but nothing really solves it and it's still present in 16.04

If you have Ubuntu 16.04 Unity as host and Windows guest in Virtualbox VM, when you are on the Windows guest using Super or Alt keys makes that both the guest and unity capture the key. Super key will open the Dashboard in Unity host and Start menu in Windows Guests and Alt key will open the HUD in Unity and any of the uses of Alt in Windows.

There are several bug reports about this. I.e.: https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/741869 https://bugs.launchpad.net/unity/+bug/1060225 ...

and the only workaround is this: How do I prevent Ubuntu from capturing the Alt key to show the HUD?

Which is simply to 'disable' the HUD key in CCSM... not a good solution.

Does someone knows a good workaround or if this is on going to be fixed? This kind of extremely annoying bug, very located, is something that makes me unable to use Ubuntu for work (Yes... I can't be working with VM and having menus of Unity popping up all time)

VirtualBox is widely used, I understand that this is a major issue but in internet I can't find a proper fix. Am I missing anything?

Note 1: I also use Linux Mint 17.3 Cinnamon and this doesn't happen there. Note 2: This happens (that I have tested) with every version since Ubuntu 14.04 Note 3: Checking similar questions about this and the different bugreports, VMWare and any other application (games, etc) that require to use the or keys, have same issue. And there is no intention to fix it in any bugreport.... it's a shame!!

  • 1
    Does anybody else using Virtualbox in Ubuntu suffers this? it can't only be me... – José Luis R.P. May 8 '16 at 19:54
2

You can also use CCSM to assign another key to show the HUD when tapped, not only to disable it. You just need to click on the <Alt> button in the same menu -the red arrow- points to in the example image (below), and then click in "Grab key combination" button instead of the "Enabled Box" and select another key combination to show the HUD.

compizconfig settings manager image example

To install CCSM use

sudo apt-get install compizconfig-settings-manager

or you can search for it in "Ubuntu Software" in unity.

Then you can start it from the Dash by searching for CCSM and then click in the "Ubuntu Unity Plugin" button.

Note: Maybe you will also want to assign another key to "Show the menu bar when pressed", because it also uses only <Alt> keystroke to function. The difference between the two is that, to show the HUD, you just need to press the key and then rapidly let go, and to show the menu bar, you need to maintain the key pressed for more than a second. I don't know if the second also affects normal behavior in a Windows VM in Virtualbox.

Note2: The same goes for <Super> key. The only difference is that the option to change this keystroke is in the "Launcher panel" in the same Unity menu in CCSM.

  • thanks to izx for the image. – Pebas May 27 '16 at 14:15
  • I appreciate a lot your response, Pebas, and the effort to put it, by my question was more related on how to fix it without doing what you said. That is, without changing my Alt or Super shortcuts. I.e.: I use Linux Mint in my daily work and it works as it should (super or alt do their work inside the VM and if I'm outside they do it in the host system). Why, if LM has this, Ubuntu can't do it in an easy way? – José Luis R.P. May 30 '16 at 10:29
  • Yes, I know it's not exactly what you asked or want. I wrote it to help, maybe you, and others, to get to know that there's another workaround because in your question you only said that you can disable the shortcut, but there's also the posibility to change it to another one, and I think this is a more useful approach. Just that. In fact, this issue also affects other applications, like Guake, for example. Sadly, like you said, this is not a definitive solution to your answer, or exactly what you want, but just another workaround. – Pebas May 31 '16 at 15:14
  • Yep... I hope Ubuntu thinks on a definitive solution some day, because for me this is a stopper for a professional use of Ubuntu Desktop. And Canonical doesn't seem to listen very much to this complain – José Luis R.P. Jun 2 '16 at 7:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.