11

Since I have Ubuntu 16.04 have not had any problems with the PS2 mouse, but a week ago I placed a new mouse USB. This mouse freezes randomly (Sometimes while I am using the PC and sometimes this happens for hours without using the PC) and I have to disconnect the mouse and reconnect it.

I have tried to restart lightdm, I have reinstalled the mouse drivers, I have changed the values of the files level, control and wakeup to y autosuspend to on, enable y -1 respectively, I get nothing.

When the mouse works correctly and I type the command xsetpointer -l | grep Pointer the terminal displays 8: " USB OPTICAL MOUSE" [XExtensionPointer] but when the mouse freezes, that line does not appear. The same happens when I type the command xinput --list, when the mouse works correctly the terminal displays USB OPTICAL MOUSE id=8 but when the mouse freezes, that line does not appear. What can happen?

Note: In Windows the mouse works correctly.

  • You could start run dmesg -w in a terminal and observe potential disconnection problems. Leave the terminal open and continue to work. If the mouse freezes, check the terminal. It seems to be a hardware failure, not a Xorg problem. Paste the resulting lines here to analyze. – kanehekili Dec 26 '18 at 23:41
0

Check for related messages with (-p comes for priority, 4 means "warning" and above: err, crit...):

journalctl -b 0 -p 4

Common cases:

  • Other USB device is the problem. In my case was a Western Digital Passport external HDD. Try disconnecting any other USB device.
  • The USB mouse cable is just broken: you have to replace it (or repair it).
  • This is a pretty common behavior with wireless mouses when they are running out of battery. If that's your case check on a terminal with

    upower -i $(upower -e | grep mouse)
    

    or with GUI, gnome-power-statistics or in Gnome Shell Power Settings:

    screenshot

0

Another possibility - maybe weird sounding but perhaps easy to try - use a different USB port or if using a USB hub, try directly connecting the mouse to the computer. I've occasionally solved a similar problem (with Windows) that way - seemed like some subtle interaction between the hardware, the firmware, and the O/S, but I've never taken the time to deeply investigate. Does your mouse light stay on when the mouse is frozen? If not, check cable, socket, or try another mouse.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.