After installing TeamViewer 11 on Ubuntu Desktop 64-bit 16.04, I get the error:

Verification of your teamviewer version failed, Teamviewer will quit for security reason. Please reinstall teamviewer

I have uninstalled and purged several times, and I always get the same error on install. TeamViewer 10 works 100% fine. I need version 11 as clients have upgraded.

  • I'm just guessing here, but I suspect that Teamviewer checks a chain of certificates, and that Teamviewer 11 needs a different CA provider from version 10. Is the package ca-certificates on your system the latest version? – Jos Apr 28 '16 at 10:46
  • It is a complete new, fresh install of Ubuntu 16.04 from cd. – Nathan Wynands Apr 28 '16 at 21:33
  • All the updates are done and the install processes through like it has worked. I followed the instructions for command line install from the Teamviewer website. – Nathan Wynands Apr 28 '16 at 21:37
  • Also, today at work i did a fresh install of 16.04 on a different HP pc. It presented with the exact same error. – Nathan Wynands Apr 29 '16 at 3:22
  • 1
    Update - This is a know bug with Ubuntu 16.04 omgubuntu.co.uk/2016/04/ubuntu-16-04-deb-software-install-error . There is currently NO FIX – Nathan Wynands Apr 29 '16 at 22:38

As first, remove the actually broken Teamviewer installation in a terminal () by:

apt-get purge teamviewer

If this does not want to work you can as well do this with dpkg:

dpkg -r --force teamviewer

After that make sure you delete any leftovers from your user directory, i.e. ~/.local/share/teamviewer11, ~/.config/temaviewer and /etc/teamviewer:

rm -r ~/.local/share/teamviewer11
rm -r ~/.config/teamviewer
sudo rm -r /etc/teamviewer

Now that this is out of the way, you do an update and an upgrade:

sudo apt-get update
sudo apt-get dist-upgrade

Then install the following packages:

sudo apt-get install libjpeg62:i386 libxinerama1:i386 libxrandr2:i386 libxtst6:i386 ca-certificates

Now download the Teamviewer package from their website (download-link) and install it:

cd ~/Downloads
sudo dpkg -i teamviewer_11.0.57095_i386.deb

After that it should run start normaly. If you not see teamviewer yet in the dash search check /usr/share/applications directory if the shortcut teamviewer-teamviewer11.desktop exists. If not create one by

sudoedit teamviewer-teamviewer11.desktop

And pasting (ctrl+shift+v) the following in:

[Desktop Entry]
Name=TeamViewer 11
Comment=TeamViewer Remote Control Application

It should show up in dash at least after a reboot. Meanwhile you can firstly start your new installed Teamviewer vie the terminal by:

teamviewer &

Now you can lock it at least already onto your launcher if you wish to do so.

  • Thank you.. After searching for 2 days this finally worked for me. I have Ubuntu 16.04 LTS (64-bit). I followed everything you said and it works now. – lara May 30 '16 at 8:01

I found a "solution":

first I purged teamviewer sudo apt-get purge teamviewer then deleted ~\.local\share\TeamViewer11

then update ubuntu, reinstall teamviewer, and it works

  • Last direcory now /teamviewer12 not /TeamViewer11 ! not first capitalize! – Pestrnko Apr 6 '17 at 14:33

protected by Community Jun 26 '16 at 18:29

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.