1

I have MAAS 1.9.1 and commissioned a node. The node is in ready state. I am behind proxy and can apt get or update. There are two interface on MAAS eth0 is on 170.x.x.x and eth 1 is on 10.x.x.x. I have eth1 setup for ip forward and masquerade. When I commissioned a new node it has no issues and downloaded Ubuntu packages etc. environment.yaml has all correct ip, keys etc. Now whether I do

  1. juju quickstart
  2. juju bootstrap

or sudo openstack-install

Juju Fails. This prevents me install Landscape - Autopilot etc

I have ran debug commands etc but no further details beside some posted below.

Some juju errors below:

The system cannot communicate with the external server ( 170.22.143.154 ).
The Internet server may be busy, may be permanently down, or may be
unreachable because of network problems.

aavam@maas-dev6-1:~/.cloud-install$ juju bootstrap
WARNING ignoring environments.yaml: using bootstrap config in file "/home/aavam/.juju/environments/maas.jenv"
ERROR cannot determine if environment is already bootstrapped.: could not access file 'e3b6a06b-9a7e-456f-8a51-a313d7d2beda-provider-state': gomaasapi: got error back from server: 504 Gateway Timeout (<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
<title>Notification: Gateway Timeout</title>

~$ juju quickstart
juju quickstart v2.2.4
ssh-agent has been started.
To interact with Juju or quickstart again after quickstart
finishes, please run the following in a terminal to start ssh-agent:
  eval `ssh-agent`

bootstrapping the maas environment
reusing the already bootstrapped maas environment
retrieving the environment status
juju-quickstart: error: the state server is not ready:
ERROR Unable to connect to environment "maas".
Please check your credentials or use 'juju bootstrap' to create a new environment.

Error details:
could not access file 'e3b6a06b-9a7e-456f-8a51-a313d7d2beda-provider-state': gomaasapi: got error back from server: 504 Gateway Timeout (<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">
  • I think it could be related to Proxy .... MAAS is behind proxy and proxy defined in env works fine for MAAS.... Apparently juju may needs its own proxy or something – aavam Apr 28 '16 at 4:39
3

Your environments.yaml will need to define http-proxy, https-proxy, and no-proxy. See here for all configuration options https://jujucharms.com/docs/1.25/config-general

1

You need the following firewall ports open:

MAAS, its nodes and the Autopilot will need to be able to reach the internet, or at least these sites (http and https):

  • maas.ubuntu.com
  • cloud-images.ubuntu.com
  • streams.canonical.com
  • an Ubuntu archive (archive.ubuntu.com or a mirror)
  • api.jujucharms.com
  • manage.jujucharms.com
  • jujucharms.com
  • store.juju.ubuntu.com
  • keyserver.ubuntu.com
  • ppa.launchpad.net
  • usn.ubuntu.com

If opening holes in a firewall, be mindful that these addresses may resolve to multiple IPs.

  • env.yaml has http-proxy, https-proxy, and no-proxy...also i can wget all the sites mentioned above...site by itself or http or https – aavam May 10 '16 at 1:46
  • firewall holes need to be opened, proxies are not good enough at this moment. – dpb May 10 '16 at 19:58
1

on MAAS server i had to IP forward and Masquerade and resolved the issue

iptables -L -n

/sbin/iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
/sbin/iptables -A FORWARD -i eth0 -o eth1 -m state --state RELATED,ESTABLISHED -j ACCEPT
/sbin/iptables -A FORWARD -i eth1 -o eth0 -j ACCEPT

sudo iptables-save

...Also make sure (both upper case and lower case)

http_proxy,HTTP_PROXY,HTTPS_PROXY,https_proxy,no_proxy and NO_PROXY in the
MAAS env is all set up......resolved the issue.......
i.e  export http_proxy=http://x.x.x.x:80  etc

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.