I've been running 15.10 since I received this laptop on Christmas. I had to use these parameters to get it to boot:

i915.preliminary_hw_support=1 nouveau.modeset=0 nouveau.noaccel=1 nomodeset acpi=0 acpi_osi=linux acpi_backlight=vendor noalpic intel_idle.max_cstate=1

Everything worked great. So I've upgraded to 16.04; the same combination parameters did not work. I found after searching around that a subset of them will and they work pretty well:

i915.preliminary_hw_support=1 nouveau.modeset=0 acpi_osi=! acpi=0 acpi_backlight=vendor idle=nomwait

The issue I have now is that the mouse pointer isn't visible the first time I boot to Ubuntu. I have to press the power button and select restart. Then it will show, but I have to move the pointer around during the login process because if I don't the mouse pointer will get stuck on the launcher which renders it useless.

This behavior was not exhibited on 15.10.

Any help would be greatly appreciated. Thank you


I carried out a fresh install of 16.04 on my ASUS GL552VW.

The only GRUB parameters I entered (for installation and normal boot) were:


To stop Nouveau from taking over.

Once I'd installed the nVidia drivers, I had to disable Secure Boot.

With those settings, everything works. Touchpad, Skylake support, nVidia graphics @ 1920x1080, Wifi, Bluetooth.

  • I modified my files to match this and it worked for me. Thanks! – Jon Delano Apr 28 '16 at 21:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.