1

I ran System Testing app on my system and it didn't seem to work properly and stopped or crashed 2 or 3 times during tests and the last time during the Optical Drive test it took so long and the test wasn't going forward so I decided to eject the DVD and so the test stopped and then the problems started.

The DVD drive used to work without problem until this test but now it's working so inconsistently. Data DVDs mostly don't get mounted at all and Video DVDs and Audio CDs get mounted but VLC or other apps either fail to play them or after few seconds stop playing and show error messages.

Since the DVD drive works perfectly and smoothly in Windows with the same DVDs, I think the drive itself is fine. System information and logs are as below. Please let me know what additional information I should provide.

Update: I can boot from a Debian Live-CD and Windows installation DVD but I can't boot from Ubuntu installation DVD that I used the last time to install.

Update2: I made a new Ubuntu installation DVD and it booted fine, so I decided to reinstall Ubuntu (and so upgrade to 16.04) and now DVD drive works great again.

Update3: Sorry about all the changes. The problem is back after few hours. It seems it's not about the test, but an Ubuntu problem. There are many similar questions and bug reports that I read and tried but no success so far.

Laptop: Lenovo G500
Ubuntu versions: 15.10 & 16.04

~$ sudo lshw -C disk
*-cdrom
   description: DVD-RAM writer
   product: DVD-RAM UJ8D1
   vendor: MATSHITA
   physical id: 0.0.0
   bus info: scsi@2:0.0.0
   logical name: /dev/cdrom
   logical name: /dev/cdrw
   logical name: /dev/dvd
   logical name: /dev/dvdrw
   logical name: /dev/sr0
   version: 8.10
   capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
   configuration: ansiversion=5 status=ready
 *-medium
      physical id: 0
      logical name: /dev/cdrom


~$ sudo mount /dev/cdrom /media/cdrom
mount: /dev/sr0 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/sr0,
   missing codepage or helper program, or other error

   In some cases useful info is found in syslog - try
   dmesg | tail or so.


~$ dmesg | tail
[ 1099.617050] sr 2:0:0:0: [sr0] tag#10 Sense Key : Medium Error [deferred] 
[ 1099.617056] sr 2:0:0:0: [sr0] tag#10 Add. Sense: No seek complete
[ 1099.617065] sr 2:0:0:0: [sr0] tag#10 CDB: Read(10) 28 00 00 23 12 7e 00 00 02 00
[ 1099.617071] blk_update_request: I/O error, dev sr0, sector 9193976
[ 1105.582540] sr 2:0:0:0: [sr0] tag#13 FAILED Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[ 1105.582554] sr 2:0:0:0: [sr0] tag#13 Sense Key : Medium Error [deferred] 
[ 1105.582561] sr 2:0:0:0: [sr0] tag#13 Add. Sense: No seek complete
[ 1105.582570] sr 2:0:0:0: [sr0] tag#13 CDB: Read(10) 28 00 00 23 12 7e 00 00 02 00
[ 1105.582576] blk_update_request: I/O error, dev sr0, sector 9193976
[ 1105.582585] Buffer I/O error on dev sr0, logical block 1149247, async page read

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.