9

I have problem with Adobe Flash Player. While using Opera, few of pages show me that I don't have flash installed. When I run this command in terminal:

sudo apt-get install flashplugin-installer,

I get information that it's already installed. So I try to use this page https://get.adobe.com/pl/flashplayer/ to install flash. When I want to install version for Ubuntu, I get internal error in /usr/bin/apturl-gtk with message:

apturl-gtk crashed with AttributeError in doEnableChannel(): module 'apt_pkg' has no attribute 'Config'

I also tried to install it manually in Opera Web Browser using this tutorial http://www.opera.com/docs/linux/plugins/install/#flash but this method also failed. Any help?

5
  • Do you have /usr/lib/adobe-flashplugin/libflashplayer.so file? – Hi-Angel Apr 27 '16 at 17:14
  • I haven't got. I created that folder and move that file to that directory. After that I rebooted Ubuntu. Still not working :( – kkochanski Apr 27 '16 at 17:23
  • Try sudo apt-get install adobe-flashplugin – Hi-Angel Apr 27 '16 at 18:01
  • Thanks, it's working. You can add this message as answer and I will mark this ;) – kkochanski Apr 27 '16 at 18:11
  • This is not really a duplicate as this question is specificially about Opera. – stommestack Dec 10 '18 at 17:27
12

There're multiple conflicting packages, e.g. flashplayer-mozilla, flashplugin-installer, adobe-flashplugin

The specific one you need for Opera browser is adobe-flashplugin, i.e.

sudo apt-get install adobe-flashplugin

Update per comments: if you get a has no installation candidate error, run software-properties-gtk, and set all checkboxes on the Ubuntu Software tab. Next update packages list with, e.g., sudo apt-get update, and try installing again.

3
  • sudo apt-get install adobe-flashplugin Reading package lists... Done Building dependency tree Reading state information... Done Package adobe-flashplugin is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'adobe-flashplugin' has no installation candidate – Jeremy May 19 '16 at 15:30
  • 1
    @Jeremy run software-properties-gtk, and set all checkboxes on the «Ubuntu Software» tab. Then update packages list with, e.g., sudo apt-get update, and try installing again. – Hi-Angel May 19 '16 at 16:20
  • @Hi-Angel: Could you please add your comment to your answer to make it more helpful? Notify me if you want an up-vote on the result. – David Foerster Oct 25 '16 at 12:07
4

That help page is seriously outdated: “This document was last updated for Opera 11.00” while the current version is 41 and Opera completely switched the rendering engine to Blink (the same as in Chromium/Chrome) in the mean time.

If you look at the packages recommended by the opera-stable package, you'll find an entry for pepperflashplugin-nonfree. This package will install the PPAPI Flash Player plug-in included with Google Chrome which will work with Opera too (otherwise they wouldn't suggest it).

Furthermore, the more recent releases of the adobe-flashplugin include the same PPAPI Flash Player without the detour through Google Chrome. You can install it as in How to install Flash player on Ubuntu?. Use karel’s answer if you're unsure since that's the recommended way to install Flash Player in Ubuntu these days, which happens to recommend the same as Hi-Angel’s answer here.

3
  • @morpheus: I rolled back your edit. It's superfluous because the installation is explained in the linked question. There's no need to replicate them here and I don't know why it was accepted in review. – David Foerster Nov 29 '16 at 4:01
  • Which answer under the linked question is the good one for Opera? – user47206 Apr 10 '18 at 17:15
  • @cipricus: See the update to my answer. – David Foerster Apr 10 '18 at 18:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.