20

I'm running Ubuntu 16.04 and I've just upgraded the firefox package (released today) from 45.0.2 to 46.0.

The release has brought an unwelcome change; the ugly Ubuntu scrollbars, and even uglier Ubuntu menu colours. How can I disable these, and get back the standard Firefox/GTK style?

Before: Firefox 45.0.2 on Ubuntu 16.04

  • Menus and textbox popups use black text on light grey background
  • Scrollbars are grey, have up/down/left/right icons

Firefox 45.0.2 on Ubuntu 16.04

After: Firefox 46.0 on Ubuntu 16.04

  • Menus and textbox popups use grey text on Ubuntu off-black background
  • Scrollbars are orange flat-design travesties

Firefox 46.0 on Ubuntu 16.04

I want to keep Firefox 46.0 but get rid of the sucky Ubuntu UI theme. Here are the steps I've already tried:

  • Checked Tools -> Addons -> Appearance to see if it's a distinct theme from the default -- it isn't, this IS the default.
  • Tried changing Firefox theme to several complete themes -- several of these changed every aspect of the Firefox UI except the scrollbars and popup menus, others did change them but I just didn't like their aesthetics.
  • Checked Tools -> Addons -> Extensions and disabled the "Ubuntu Modifications" addon. This didn't help.
  • From the old "how do I disable overlay scrollbars?" question, I tried apt-get remove overlay-scrollbar, then restarting my session. This didn't help.
  • From the same question, I tried gsettings set com.canonical.desktop.interface scrollbar-mode normal and this didn't help either.
  • From the same question, I tried launching Firefox with LIBOVERLAY_SCROLLBAR=0 firefox and also GTK_OVERLAY_SCROLLING=0 firefox, neither of these worked.

What has worked so far is downgrading to the previous firefox package

apt-get install firefox=45.0.2+build1-0ubuntu1
apt-mark hold firefox

This works perfectly, so it does show that the problem is specific to the new 46.0+build5-0ubuntu0.16.04.2 version of the package. I looked at the Ubuntu package changelog which doesn't say much, but the Firefox 46.0 release notes say "GTK3 integration"; Firefox 46.0 switched from using GTK2 to using GTK3, as Compholio noted in their answer.

This isn't a permanent solution, I don't want to fall behind the latest Firefox release. What can I do to get the vanilla GTK theme in Firefox instead of the Ubuntu theme?

2
  • 1
    don't want too much 'me too' here -- but I have the same issue on 14.04 – badgley May 4 '16 at 2:42
  • What the OP colorfully calls here " the sucky Ubuntu UI theme" is a default theme that Firefox follows instead of the selected one. This is an old problem, but I have met it in newer Firefox, and solved it as said in the answer below. It is not desktop-specific (e.g. Unity or Gnome), but a GTK-version compatibility problem between Firefox and the selected themes. – cipricus Mar 15 '20 at 13:36
4

This appears to be a bug with the GTK3 theme, probably Firefox is using the wrong theme information for the pop-ups and the scroll bar.

I partially fixed this for myself by switching the theme for just Firefox:

GTK_THEME=radiance firefox

You can add this "permanently" by editing the launcher file:

sudo gedit /usr/bin/firefox

and adding the line (after #!/bin/sh):

export GTK_THEME=radiance

It'd probably be a good idea to file a bug against this, but now that I've finally gotten rid of the awful dark menus I'm less motivated to find the root cause of the problem ;)

2
  • I like this answer. It's not the same as Firefox 45, but it's aesthetically better than the default Ambiance theme look. I note that it's actually the default theme (Adwaita?). Using GTK_THEME=Radiance firefox uses the Radiance theme, which is also better than Ambiance (no black popups), but still has the orange scrollbars. Using the name of a theme which doesn't exist always selects the default theme, which doesn't have some of the familiar Ubuntu stylings (e.g. dark background in the top tab bar, orange highlighted menu items instead of blue), but it's better looking than Ambiance – Stuart Caie May 19 '16 at 12:26
  • This also works for Quantum (e.g. 73.0.1) when the scrollbar follows a default theme instead of the selected one. Another way is to use the line Exec=env GTK_THEME=<THEME_NAME> firefox in /usr/share/applications/firefox.desktop or ~/.local/share/applications/firefox.desktop. – cipricus Mar 15 '20 at 13:26
2

What you could do is to install and use a complete theme for Firefox that includes its own scrollbars etc. This won't look like the old default, but I bet you can find something similar or even nicer.

In the Tools menu, select Add-ons, there go to the Get add-ons tab and scroll down the page. In the lower left corner is a link See all complete themes. This should bring you to Mozilla's Firefox homepage and their complete-theme site. Alternatively, click this link.

Pick one of the available free themes that is compatible with Firefox 46 and pleases your eyes, click on its green + Add to Firefox button and after the download completed, confirm the speech bubble asking for your permission by clicking Install.

Then you will be asked to restart Firefox which you should do, and the new theme will get enabled.

To change the theme again to a different or the default one and to remove no longer wanted themes, open the Tools menu, select Add-ons and navigate to the Appearance tab where you see a list of all installed themes.

PS: My personal favourites are "BlackFox V2" and "NASA Night Launch" (Yes, I love dark themes...)

3
  • 1
    Thanks for the suggestion, but it didn't appear to work. I tried the top three complete themes, and while they did re-theme Firefox, none of them change the scrollbars or menu-popups. I've updated the question with this info – Stuart Caie Apr 27 '16 at 17:09
  • Both themes I suggested actually do change the scrollbars and dropdowns for me on 16.06 with Firefox 46. Maybe you should try reverting the scrollbar-related settings of Unity to their defaults or something else first... – Byte Commander Apr 27 '16 at 17:59
  • 1
    OK, this time I checked both BlackFox V2 and NASA Night Launch, you're right - they do change the scrollbars. So the theme can change these UI elements, but not all themes in the "complete themes" category will do that. I'll have a look to see if any of the themes are regular-GTK-ish – Stuart Caie Apr 27 '16 at 18:11
0

Not sure if it will work because I don't have this issue but my firefox is synced with my windows system and that may be why.

If you click on the button in the right top corner (where you would click to get to preferences) then click on Customize in there you should see themes .. maybe try selecting a different theme might set it right.

Not the answer you're looking for? Browse other questions tagged or ask your own question.