16

Why has Avidemux been removed from Ubuntu 16.04?

9

I think nobody outside Canonical can answer that authoritatively, and an answer wouldn't be productive anyway.

If you want to know how to use recent avidemux versions on xenial, there are several PPAs around.

The ppa from Thanh Tung Nguyen seems to be of good quality, but unfortunately, the last release failed to build. There is also a getdeb.net ppa which specializes in obscure software, and it has the latest avidemux 2.6.12. You need to install the avidemux2.6-qt version or the avidemux2.6-cli version. For me, it runs without issues.

  • Just want to point out the convenience and reliability of getdeb.net, which I have used without any issues for years, for installing 3rd party software (much before snappy and flatpak existed). – Jose Gómez Jul 21 '16 at 22:50
  • 1
    I believe this is the authoritative answer: answers.launchpad.net/ubuntu/+source/avidemux/+question/289466 The only explanation given is that "there was a problem in building it". – Nateowami Aug 15 '16 at 13:23
  • 2
    Ubuntu developer and Canonical employee here. Anyone can answer the question authoritatively. Ubuntu is developed as a public project; Canonical has no special privilege here. fkraiem is correct in his comment against the question (it should be the accepted answer IMHO). He links to the page that provides the audit trail. The package was removed because it was blocking the x264 library transition. That is: it didn't work with the new version of the library that Xenial was being updated to during development, and wasn't fixed before Xenial was released. – Robie Basak Sep 16 '16 at 0:10
  • one can now decide between qt4 and qt5 implementation so the package with the gui is called avidemux2.6-qt4 or avidemux2.6-qt5 – x29a Oct 26 '16 at 10:44
-1

You can use the binaries from wily, they work under xenial as well (I use it frequently). Just get the .deb files from

https://launchpad.net/ubuntu/+source/avidemux/1:2.5.4-0ubuntu16

and install using

sudo dpkg -i FILENAME

If there are error messages you are still missing one of the deb files (read the error message and download the .deb file you need).

At the end do a

sudo apt-get install -f

to download the other dependencies automatically (libfaac, etc.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy