1

I'm trying to config ubuntu 16.04 on a MSI s12 notebook, but the network adapter (RTL8723AE PCIe Wireless Network Adapter) is not recognized by ubuntu.

$ iwconfig syas:

    lo        no wireless extensions.     
    enp2s0    no wireless extensions.   
    wlp1s0    IEEE 802.11bgn  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
              Retry short limit:7   RTS thr=2347 B   Fragment thr:off
              Power Management:off

here are the results of $ ifconfig:

enp2s0    Link encap:Ethernet  HWaddr 44:8a:5b:41:3e:1d  
          inet addr:192.168.1.54  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::468a:5bff:fe41:3e1d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4371 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5119 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2875904 (2.8 MB)  TX bytes:586687 (586.6 KB)
          Interrupt:29 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:3814 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3814 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:295586 (295.5 KB)  TX bytes:295586 (295.5 KB)

wlp1s0    Link encap:Ethernet  HWaddr 54:27:1e:19:7f:12  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

In regard to rfkill list Nothing is blocked:

0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

Modem Model

$ lspci -vvnn | grep -A 9 Network returns:

01:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723AE PCIe Wireless Network Adapter [10ec:8723]
    Subsystem: AzureWave RTL8723AE PCIe Wireless Network Adapter [1a3b:2114]
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 31
    Region 0: I/O ports at e000 [size=256]
    Region 2: Memory at fea00000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: rtl8723ae
    Kernel modules: rtl8723ae

What I already have done?

I Have Followed this solution: https://askubuntu.com/a/645238/196157 which suggests:

sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo apt-get update
sudo apt-get install rtlwifi-new-dkms linux-firmware

and this one: install a newer driver that says:

wget https://github.com/lwfinger/rtlwifi_new/archive/rock.new_btcoex.zip
unzip rock.new_btcoex.zip
cd rtlwifi_new-rock.new_btcoex
make
sudo -i
make install
echo "options rtl8723be ant_sel=2"  >  /etc/modprobe.d/rtl8723be.conf
exit

Reboot.

I Also installed WICD as instructed here: Installing WICD. But there is no wireless Adapter working.


Updates

  1. I installed bcmwl-kernel-source package. 1.1. removed.
  2. sudo modprobe wl && dmesg | grep wl returns:

3. sudo lshw -C network

  *-network               
       description: Wireless interface
       product: RTL8723AE PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: wlp1s0
       version: 00
       serial: 54:27:1e:19:7f:12
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723ae driverversion=4.4.0-21-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:31 ioport:e000(size=256) memory:fea00000-fea03fff
  • 1
    What's module wl doing in there? That's a Broadcom proprietary driver, and should not be used. Blacklist it? – ubfan1 Apr 27 '16 at 19:51
  • I'm going to purge it. – Odysseus Apr 28 '16 at 7:28
3

Make the parameter permanent with the terminal:

sudo -i
echo "options rtl8723ae msi=1"  >  /etc/modprobe.d/rtl8723ae.conf
exit

Upon boot you should be all set.

1

The Problem is solved using this post:

  1. Clone project: git clone git@github.com:lwfinger/rtlwifi_new.git
  2. Build project: make; sudo make install
  3. Remove the old mod: sudo rmmod rtl8723ae
  4. Set the mod with the msi flag: sudo modprobe rtl8723ae msi=1
  • 1
    but the problem is that how to make sudo rmmod rtl8723ae and ` sudo modprobe rtl8723ae msi=1' permanent? – Odysseus Apr 27 '16 at 18:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.