19

I'm new to Ubuntu and just recently installed the Version 16.04 My Touchpad is not working at all and it seems as if it is not detected. The USB Mouse however is working perfect. I'd like to use the Touchpad though.

Is there a way to get it working?

I'm using a MEDION akoya E5218 notebook.

I did not disable it. I tried Fn+F6.

5
  • 2
    Maybe you disabled it. Try FN+F6
    – Motte001
    Commented Apr 27, 2016 at 15:21
  • in settings menu click on mouse and touch pad then choose "tap to click" option
    – guest
    Commented Aug 5, 2016 at 19:32
  • Only command worked for me sudo modprobe -r psmouse sudo modprobe psmouse proto=imps
    – raj
    Commented Jan 15, 2017 at 4:38
  • @Motte001 this is what happened to me. In my case, it is Fn+F7, but in general it depends on the keyboard layout. Luckily mine is drawn onto my keyboard. Commented Nov 12, 2017 at 0:33
  • First check if Touch-pad isn't disable from mouse & Touch-pad setting.
    – QMaster
    Commented May 9, 2019 at 16:00

6 Answers 6

16

My touchpad sometimes gets stuck (especially on a fresh boot).

In my case, reloading the driver works. First I unload the module from the kernel (using rmmod (remove module)) and then reinsert it (using modprobe):

sudo rmmod i2c_hid
sudo modprobe i2c_hid
0
12

If you type

less /proc/bus/input/devices

do you see a touchpad anywhere in that list? If not, then there is no support for your touchpad in the kernel and you are pretty much out of luck, at least for now. If your touchpad is detected then the problem is elsewhere. Typing

xinput

will show if the X server has detected your touchpad. If your touchpad is in that list it may be possible to modify the X config to make it work

4
  • Can you explain How to change the xinput value? My touchpad is listed there.
    – Kolappan N
    Commented Aug 26, 2016 at 17:50
  • @DavidFoerster It is not my question. I faced a similar problem. So I commented on the accepted answer to get more details. The answer said we can modify x config value to fix things. I was asking him some detailed steps or reference links. Again, It is not my question.
    – Kolappan N
    Commented Oct 1, 2016 at 9:14
  • @KolappanNathan: Sorry, my oversight. Never mind then. Commented Oct 1, 2016 at 9:21
  • Touchpad is not listed.. Is there a driver I can install?
    – moonstar
    Commented Dec 28, 2016 at 7:57
9

Follow these instructions to fix the issue,

modify grub file,

sudo nano /etc/default/grub

replace

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

with

GRUB_CMDLINE_LINUX_DEFAULT="i8042.reset quiet splash"

Save the file and then update grub using,

sudo update-grub command. and then restart your OS,

sudo shutdown -r now
1
  • Thank you so much it works for me and also it fixes another issue I have with the CAPS Lock that was always on :) Commented Jul 25, 2019 at 7:14
6
  1. Edit GRUB

    sudo -H gedit /etc/default/grub
    

    In the open window edit line

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    

    It should look this way

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.nopnp"
    

    Save file and run

    sudo update-grub
    
  2. Prevent i2c_hid from loading

    echo "blacklist i2c_hid" | sudo tee /etc/modprobe.d/i2c-hid.conf
    sudo depmod -a
    sudo update-initramfs -u
    echo "synaptics_i2c" | sudo tee -a /etc/modules
    
  3. Reboot.

What it does is, it removes the synaptics hid drivers from the blacklist and allows them to be loaded at the initialization of the RAM file system, allowing your touch pad to work at boot

5
  • Don't use sudo for graphical applications; use gksudo instead! Commented Oct 1, 2016 at 8:53
  • @FatemehKarimi Glad it worked for you :) Commented Jan 22, 2018 at 9:58
  • This worked for me on HP Elitebook 1050. Thank you!
    – ak93
    Commented Feb 12, 2019 at 18:17
  • It also worked for Acer Aspire 3 Ryzen5 AMD processor.Thanks:) Commented Jul 11, 2019 at 12:49
  • But scroll option with two fingers is disabled and lot available in tochpad option which ws available before this. Commented Jul 12, 2019 at 11:19
1

For my Akoya laptop this worked fine:

1. Try the following:

  • reboot to the grub menu and type e (hope it is right, --> you have to edit your command line)

  • in the line starting with GRUB_CMDLINE_LINUX_DEFAULT insert the following kernel properties:

      "i8042.reset i8042.nomux=1 i8042.nopnp i8042.noloop"
    
  • if your touchpad is now working, go to point 2.

2. Permanent Grub modification

  • Make a backup of your grub file:

      sudo cp /etc/default/grub /etc/default/grub.backup 
    
  • Edit your grub file:

      sudo nano /etc/default/grub 
    
  • Now add the following paramters into the line starting with GRUB_CMDLINE_LINUX_DEFAULT :

      "i8042.reset i8042.nomux=1 i8042.nopnp i8042.noloop"
    
  • Save the file

  • Update your grub

      sudo update-grub
    
  • Reboot.

0

Perhaps you need to upgrade your kernel. I find that Ubuntu kernels below 4.5 don't find my Elantech touchpad by default.

You can upgrade to a newer version, like 4.5 using the instructions found here:

How to update kernel to the latest mainline version without any Distro-upgrade?

1
  • I checked this, nothing worked. Commented Jul 12, 2019 at 11:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .