6

I have Ubuntu 16.04 installed in my computer, I have Broadcom Wifi in my computer. This wifi is not able to connect to the weak wifi signals around the computer, these are connected by my friends' laptops having Windows and my Smart Phone can too connect to the wifi, but my laptop cannot connect to those signals, in my hostel given to the students.

For the PC, info i ran command

sudo lshw -c network

and the output was:

*-network
       description: Wireless interface
       product: BCM43142 802.11b/g/n
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:06:00.0
       logical name: wlp6s0
       version: 01
       serial: ac:d1:b8:ca:93:d5
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet  physical wireless
       configuration: broadcast=yes driver=wl0 driverversion=6.30.223.248 (r487574) ip=172.16.14.193 latency=0 multicast=yes wireless=IEEE 802.11abg
       resources: irq:18 memory:f7200000-f7207fff

and the driver information i got from the the settings is given under:

enter image description here

Please help me I initially had Ubuntu 14.04, same problem was there then I washed it and newly installed Ubuntu 16.04, the problem continues here too.

And at my home, we have a good wifi, strong signal, it connects easily.

So please help me.

  • Please run the ubuntu forums wireless script (github.com/UbuntuForums/wireless-info) at a location you find difficult and paste the results into paste.ubuntu.com then edit your question to include a link to it. – Steve Roome Jun 18 '16 at 19:11
2
+50

I've been using Linux for a while in many multiple computers, work, home, the laptop I got from work, girlfriend's computer... And I never had a worse experience than with the Wifi card you have. My employer gave me a Dell Vostro 3306 if I recall correctly, which had this card.

The solution I found was simply to change the Wireless adapter. I tried many things, different drivers, distros and approaches; and I ended up using a card from a dead notebook. Replacing the Wifi card is very easy, so don't be afraid. Trust me, you'll save a lot of time by using a different card, and they are not expensive.

If you remind me later, I can send you the models I have in my 2 laptops, which work great in Linux, without any strange setup.

Maybe this is not what you were expecting as an answer, but at least will help you save time -or invest it in the right things.

Good luck!

0

This is quite normal and also happens in windows (maby to a lesser extent). Your friend's laptop and phone may have a better wireless card than your laptop. When i put my laptop right next to my brother's laptop that runs windows 10, I, on ubuntu 16.04, get a lot better wifi signal than he does, despite being in the same position. His windows phone also gets a lot better reception than his laptop with windows on it.

To see the signal strengths of your networks, could you run the following command and paste it here:

sudo iwlist scan |grep -e Signal

(add -e ESSID to the end if you want to see which signal strength belongs to what network, sudo iwlist wlp7s0 scan |grep -e Signal -e ESSID)

-3

I am using Ubuntu 15.10. I too had this same problem. The only solution that worked for me is to change the network driver.

Try this ...

https://github.com/lwfinger/rtlwifi_new

download the zip file and unzip it.

In the unzipped folder,right click and select open in terminal,Then enter the following commands

make
sudo make install
sudo modprobe -rv rtl8723be
sudo modprobe -v ips=0 ant_sel=0
echo "options ant_sel=2" | sudo tee /etc/modprobe.d/rtlbetcoex.conf

Then reboot the system.. and it should work. I tried it and it worked for me. Good luck

  • 3
    Are you sure about this ?? "rtlwifi" Drivers are meant for Realtek Network Cards, and the OP is using Broadcam one. – Severus Tux Jun 18 '16 at 3:00
  • Hey I tried to do sudo modprobe -v ips=0 ant_sel=0, and it gave error – Nimit Bhardwaj Jun 19 '16 at 6:15
  • modprobe: FATAL: Module ips=0 not found in directory /lib/modules/4.4.0-24-generic – Nimit Bhardwaj Jun 19 '16 at 6:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.