45

I feel one of the biggest improvements with Chrome on Windows is moving the tabs all the way to the top to the screen (so the mouse can just go all the way up, then click). I went with the kubuntu because they do not include the normal (pointless) Linux menu bar at the top of the screen. It took me an hour to get chrome on here and now I see there is a Giant pointless title bar across the top. It is a good 5% of the total screen area and it is just the title and close buttons. Is there anyway to have the chrome tabs all the way at the top of the screen like was intended by Google?

0
94

Go to Chrome MenuSettingsAppearance section, unmark Use system title bar and borders.

8
  • 2
    That didn't work with unity when at maximum size of the window. Mar 22 '18 at 8:27
  • 1
    It worked for me, on Linux Mint Mate.
    – apaderno
    Aug 6 '18 at 21:49
  • 2
    Works for me on Manjaro with KDE Plasma. Thanks!
    – knaos
    Nov 2 '18 at 8:50
  • 1
    How to do this from console ??? Mar 6 '19 at 15:19
  • 2
    Works for me too in the plasma desktop.
    – tripulse
    Sep 15 '19 at 3:00
1

Open system settings (the systemsettings app), and go to WorkSpace Appearance → Window Decorations → Configure Decoration. Switch to the Window-Specific Overrides tab. There you have to add a new override, press Add button, you will see a new window with checkboxes. Press Detect Windows Properties button (your mouse cursor will turn into aim like icon), and click at the Google Chrome window. You will be prompted of whether to use window class, or just title, choose the window class checkbox. Finally, check Hide window title bar checkbox, press ok.

Note that you can move windows by holding Alt key and clicking them.

1
  • 1
    In the System Settings of Kubuntu 16.04 LTS (KDE 5) the item "WorkSpace Appearance" is renamed to "Application Style".
    – user300458
    Apr 27 '16 at 14:00
1

For those who also would like to get rid of window buttons (minimize, maximize, close).

Right-click the titlebar of Google Chrome, go to More ActionsConfigure Special Application Settings...Appearance & Fixes tab, mark No titlebar and frame, in the following menu select Force and then Yes on the right, click OK to save new settings.

If you need to access the window manager's menu in KDE (like right-clicking the titlebar), you can always use Alt+F3 shortcut.

1

In the latest build of Chromium, version 94 now, the Menu ⇒ Settings ⇒ Appearance ⇒ Use system title bar and borders option is no longer available there.

What you need to do to access this option is Right Click in any empty space in the Tab Bar and select or deselect the Use system title bar and borders option from the drop down menu, as shown in the screenshots below below.

Use system title bar and borders option - Selected: Use system title bar and borders - Selected

Use system title bar and borders option - Deselected: Use system title bar and borders - Deselected

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.