4

When I boot up, I see the x-windows where I can enter my login, then it gives me a blank desktop background where I see a mouse pointer and nothing else. I can switch to a TTY.

I get these errors on Ubuntu 15.10 and 16.04

$ cat ~/.xsession-errors
openConnection: connect: No such file or directory
cannot connect to brltty at :0
upstart: Failed to spawn upstart-udev-bridge main process: unable to execute: No such file or directory
upstart: unity-gtk-module pre-start process (1418) terminated with status 127
upstart: dbus pre-start process (1425) terminated with status 127

Any suggestions on what I could do?

  • this could also be related but does not appear to give a solution - bugs.launchpad.net/ubuntu/+source/unity-greeter/+bug/1537616 – Nayeem Syed Apr 27 '16 at 12:39
  • I had altered my /etc/environment file and had this issue. The problem was that the PATH variable no longer could see the upstart-udev-bridge command because it is in/sbin. Replacing the line: PATH=$PATH:/bin:/sbin:/usr/bin:/usr/sbin at the top of that file fixed my issue. – aaiezza Jan 12 '17 at 17:40
3

I had altered my /etc/environment file and had this issue. The problem was that the PATH variable no longer could see the upstart-udev-bridge command because it is in/sbin. Replacing the line: PATH=$PATH:/bin:/sbin:/usr/bin:/usr/sbin at the top of that file fixed my issue.

| improve this answer | |
1

I had the same problem. But it vanished once I did the following:

  1. Ctrl+Alt+F1 to get to command line login.
  2. Log in using user account you have setup during installation.
  3. sudo apt-get update followed by sudo apt-get upgrade
  4. reboot. When I logged in again, it worked.

Turns out many packages including upstart get upgraded with the bug fixed.

Hope this helps others.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.