3

I recently upgraded to Ubuntu 16.04 LTS from 14.04 LTS. All worked pretty fine except for an issue on Chinese fonts which I've been unable to resolve.

While the font is mostly OK in system applications, it doesn't work well in Chrome: It seems that Chrome automatically uses Noto Sans font as the fallback font, which for some reason is only installed in its "thin" variant in 16.04 LTS and thus looks very ugly. In Firefox and many other applications, the font Wenquanyi Zenhei is correctly used as the fallback font and it looks much better. If I delete Noto Sans from the system, Chrome just gives me blank squares instead of trying to use Wenquanyi Zenhei.

I'm not sure why that's happening. Is this something specific to Chrome, that Google intends it to use its own Noto Sans font for fallback? Or is it something about system configuration? Or is there some setting in Chrome that I can change? How can I change the fallback font for CJK?(systemwide or just for Chrome)

3

There seems to be some bug in the fontconfig package (I reported the bug) which somehow let Chrome believe that "thin" is the correct weight to use. I removed the package and downloaded NotoSansCJK directly from Google, which contains fonts of different weights in separate files. After installing the fonts manually this issue seems to be fixed, and Chrome is able to render CJK correctly even though my default font is still unchanged (Liberation Sans)

1

The “Noto Sans CJK" font is over 100MB, it is a complete fonts with all weights and all characters in CJK.

Any way, there is something wrong there. My work-around is: In chromium settings -> customize fonts, change "standard font" to use "Noto Sans CJK", like me use "Noto Sans CJK SC"; I think maybe for Chrome, it is the same.

You can refer to this qustion or this bug to see more info.

  • Yeah, that bug report addresses the problem in comment #113, but doesn't really provide a solution. Does setting the standard font in Chromium result in proper rendering of all the font weights, with "Regular" as default? – Gunnar Hjalmarsson Apr 27 '16 at 12:33
  • 1
    @GunnarHjalmarsson at least, in my Chromium, "Regular" and "Bold" are showing fine and "Regular" is default. I have "en_US.UTF-8" as $LANG in env. But I don't know how to test other weights. – alfred Apr 27 '16 at 12:52
  • Did that impact your English font rendering though? I still want to use Liberation Sans as my default sans font for Latin scripts. It seems that the default Latin font in Noto is different from Liberation Sans/Arial/Helvetica series – xji Apr 27 '16 at 13:05
  • @XiangJi, In my Chromium, for askunbunt, changing "standard font" does not affect English font to render. From Chromium inspect tool, it shows English words are shown as "Ubuntu". – alfred Apr 27 '16 at 13:21
  • 1
    @alfred Sure, that's because AskUbuntu has a font "Ubuntu" defined, so it won't be affected by user setting here. But there could be a difference on websites that does not define what font to use and automatically falls onto the default font, for example Wikipedia. – xji Apr 27 '16 at 13:30

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.