1

I'm running ubuntu-core-15.10-core-armhf.tar.gz on a arm evaluation board. Without any change the board boots up ad ask login on ttyPS0 (Started Serial Getty on ttyPS0.). If I try to use ubuntu-core-16.04-core-armhf.tar.gz the board boots up and the console login doesn't work [ TIME ] Timed out waiting for device dev-ttyPS0.device. [DEPEND] Dependency failed for Serial Getty on ttyPS0. Is there a problem on 16-04 ubuntu-core release or I need to modify somothing on the file system?

0

I had the same boot issue with UBuntu core 16.04 on ARM. When I created a symlink to /lib/systemd/system/getty@.service under /etc/systemd/system/getty.target.wants I could get the console working

ln -s /lib/systemd/system/getty@.service getty@ttyAMA0.service

Since ttyAMA0 is a serial device I initially tried creating a symlink to /lib/systemd/system/serial-getty@.service (I suppose this should be the right thing to do based on some systemd blogs) but this didn't seem to have any effect. Maybe someone can throw more light on this.

| improve this answer | |
0

Solved as suggested by user538582 with

ln -s /lib/systemd/system/getty@.service /etc/systemd/system/getty.target.wants/getty@ttyPS0.service

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.