7

X2GO with Ubuntu Mate 16.04 fails to start with the following error message in ~/.xsession-x2go-errors

XSession-x2go: X session started for testuser at Fri Apr  26 22:30:23 EDT 2016
localuser:testuser being added to access control list
/etc/x2go/Xsession: 3: [: x: unexpected operator
mate-session[3684]: GLib-GIO-CRITICAL: g_settings_schema_source_lookup: assertion 'source != NULL' failed
mate-session[3684]: GLib-GIO-ERROR: No GSettings schemas are installed on the system
aborting...
6

To work around the problem set in ~/.profile the system default value for XDG_DATA_DIRS and to GSETTINGS_SCHEMA_DIR.

export GSETTINGS_SCHEMA_DIR=/usr/share/mate:/usr/share/mate:/usr/local/share/:/usr/share/:/var/lib/snapd/desktop

export XDG_DATA_DIRS=/usr/share/mate:/usr/share/mate:/usr/local/share/:/usr/share/:/var/lib/snapd/desktop
| improve this answer | |
2

great idea! I had this issue too. If you want to have x2go with Mate working for all users enabled I would put this

export GSETTINGS_SCHEMA_DIR=/usr/share/mate:/usr/share/mate:/usr/local/share/:/usr/share/:/var/lib/snapd/desktop
export XDG_DATA_DIRS=/usr/share/mate:/usr/share/mate:/usr/local/share/:/usr/share/:/var/lib/snapd/desktop

into /etc/profile instead. Have fun!

| improve this answer | |
0

same thing on xfce4 but I didn't have the same error message: more a lot of error message as:

    (polkit-gnome-authentication-agent-1:28411): GLib-GObject-CRITICAL **: g_object_ref: assertion 'G_IS_OBJECT (object)' failed

(polkit-gnome-authentication-agent-1:28411): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

(polkit-gnome-authentication-agent-1:28411): Gdk-CRITICAL **: gdk_cairo_surface_create_from_pixbuf: assertion 'GDK_IS_PIXBUF (pixbuf)' failed

(polkit-gnome-authentication-agent-1:28411): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

(polkit-gnome-authentication-agent-1:28411): Gtk-WARNING **: Error loading theme icon 'gtk-cancel' for stock: Unrecognized image file format

(polkit-gnome-authentication-agent-1:28411): Gtk-WARNING **: Error loading theme icon 'image-missing' for stock: L'icône « image-missing » n'est pas présente dans le thème elementary-xfce-dark

(polkit-gnome-authentication-agent-1:28411): GLib-GObject-CRITICAL **: g_object_ref: assertion 'G_IS_OBJECT (object)' failed

(polkit-gnome-authentication-agent-1:28411): Gdk-CRITICAL **: gdk_cairo_surface_create_from_pixbuf: assertion 'GDK_IS_PIXBUF (pixbuf)' failed

(polkit-gnome-authentication-agent-1:28411): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

(polkit-gnome-authentication-agent-1:28411): Gtk-WARNING **: Error loading theme icon 'gtk-cancel' for stock: Unrecognized image file format

(polkit-gnome-authentication-agent-1:28411): Gtk-WARNING **: Error loading theme icon 'image-missing' for stock: L'icône « image-missing » n'est pas présente dans le thème elementary-xfce-dark

(polkit-gnome-authentication-agent-1:28411): GLib-GObject-CRITICAL **: g_object_ref: assertion 'G_IS_OBJECT (object)' failed

(polkit-gnome-authentication-agent-1:28411): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

(polkit-gnome-authentication-agent-1:28411): Gdk-CRITICAL **: gdk_cairo_surface_create_from_pixbuf: assertion 'GDK_IS_PIXBUF (pixbuf)' failed

now its working by just adding the 2 lines from your post and change mate to xfce4

| improve this answer | |
  • Can you share the them? – nkef Apr 28 '16 at 17:07
  • Fixes the icons, but still doesn't work. Many applications (eg Firefox) don't start. – Aleksandr Dubinsky May 4 '16 at 21:44
  • Also, I think the correct settings for Xubuntu are: export GSETTINGS_SCHEMA_DIR=/usr/share/gconf/schemas:/usr/share/glib-2.0/schemas; export XDG_DATA_DIRS=/usr/share/xubuntu:/usr/share/xfce4:/usr/local/share/:/usr/share/ – Aleksandr Dubinsky May 4 '16 at 22:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.