I recently updated form 15.10 to 16.04, I live on a campus, and we have to sign in for internet through 802.1x. I did everything same as I did it on 15.10, but I can't sign in on ubuntu 16.04. After i enter password, login window shows again and again and so on. I am pretty sure password is correct, because i'm using it in Windows. I also tried to remove all networks and add new one or restart network-manager, neither of it helped. I already try this https://askubuntu.com/a/465222/517465, but it didn't help either.

jjnovo@jjnovo:~$ sudo gedit /etc/NetworkManager/system-connections/TUL

(gedit:5906): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

** (gedit:5906): WARNING **: Set document metadata failed: Nastavení atributu metadata::gedit-spell-enabled není podporováno

** (gedit:5906): WARNING **: Set document metadata failed: Nastavení atributu metadata::gedit-encoding není podporováno

Where can be problem?

I tried too sudo vi /etc/NetworkManager/system-connections/TUL and edit system-ca-certs=false unfortunately this doesn't work too.

And when i boot from usb stick Ubuntu 15.10 everything work just fine, from usb stick with 16.04 nothing.

  • Did you make sure your keyboard set is correct? If not the default English layout, it sometimes get changed when upgrading. – J. Chomel Apr 27 '16 at 7:33
  • I did, I even mark "show password", everything was OK. – Kuba Novosad Apr 27 '16 at 7:35
  • I already try this answer, it didn't help me. jjnovo@jjnovo:~$ sudo gedit /etc/NetworkManager/system-connections/TUL (gedit:5906): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files ** (gedit:5906): WARNING **: Set document metadata failed: Nastavení atributu metadata::gedit-spell-enabled není podporováno – Kuba Novosad Apr 27 '16 at 8:04
  • Sorry, please help me. :) – Kuba Novosad Apr 27 '16 at 8:14
  • This error means you cannot use gedit on your system. Do it with sudo vi /etc/NetworkManager/system-connections/TUL instead if you could. – J. Chomel Apr 27 '16 at 8:17

I think I have found a simpler work around for this.

I still use the usual Network Connections interface to populate all the 802.1x Security tab including the password (this is neccessary to activate the 'Save' button even though the password isn't stored correctly).

I then open a terminal and run "nmtui-connect" and activate the connection there, it prompts for the password and attempts to connect. In all of my tests I have been connected successfully.

Interestingly the password then persists between log-ins and the "Password" section of 802.1x Security tab is populated.

  • Thanks for the workaround, solves the problem for me. This seems to be a bug in the nm-applet. I could not find a filed bug, is there one, or should I open one? – noleti Sep 7 '16 at 3:44
  • Yes, please do! I haven't filed one... – Eagle91 Sep 8 '16 at 12:05
  • doesn't work for me, I'm not using any certificate and it loops over and over. I've a @ in password, I don't think that would be causing any trouble. – Rishabh Agrahari Oct 12 '17 at 12:18

I also have same problem. Strangely, the wired network won't work, while the wireless network can connect to a 802.1x network.

Anyway, in my case, I can not fix it, but can workaround by modify the interface file Let the NetworkManager bypass the interface.

In the /etc/network/interface file

auto enp0s25
iface enp0s25 inet dhcp
       wpa-driver wired
       wpa-conf /etc/wpa_supplicant/wpa_wired.conf

and in your /etc/wpa_supplicant/wpa_wired.conf file


In my case, I can connect to network temporary.

  • So shoud it look like something like this? link – Kuba Novosad Apr 27 '16 at 13:11
  • yes. you can use reference to help.ubuntu.com/community/Network802.1xAuthentication. And use wpa_supplicant -D wired -i eth0 -c /etc/wpa_supplicant/wpa_wired.conf to check your configuration is working or not. – Jiang Junyu Apr 27 '16 at 14:38
  • enp0s25 is the network device name, make sure you use the correct device name in your configuration file. – Jiang Junyu Apr 27 '16 at 14:41
  • So instead of wifi indicator now i can see LAN indicator (2 arrows different way) but still no internet – Kuba Novosad Apr 27 '16 at 16:36
  • you can use wpa_supplicant -D wired -i eth0 -c /etc/wpa_supplicant/wpa_wired.conf command, and the authentication will print out on the screen, you can check if the authentication is success or not. Once you pass the authentication, use another session, do a "dhclient [interface]" to get your ip. – Jiang Junyu Apr 28 '16 at 1:01

There is a typo in Jiang Junyu's answer, but it works anyway.


    password="yourpassword" }

I have a similar problem.I use wired 802.1x auth wich works fine with ubuntu 14.04 and 12.04 .In 16.04 works only if i write in clear text the password (password='mypassword') in /etc/NetworkManager/system-connections/myconn.

  • works for me, but maybe not for tha author of the question – aleskva May 30 '16 at 0:44
  • what do you mean by 'clear text'? – Rishabh Agrahari Oct 12 '17 at 12:17

I had a similar situation. Seemingly my wired 802.1x connection would loop where I enter my credentials and it would try to load and then just bring up the password screen again without telling me my credentials were wrong. This is characteristic to incorrect CA certificate.

To fix it, follow one of the following below:

If you are using CA Certificates, make sure you get it from school's IT center (in my case the certificate from the previous semester was no longer valid). Once you have the CA certificate, add the path of the location of this certificate in the following location.


Find the block of text that looks similar to below


You can of course require no CA certificate. Edit your connection through 'Network Connection' GUI and check 'No CA Certificate Required' or delete (if exits) the line




Lastly, you can try to get the CA certificate from your colleagues at school who have it working or if you have a Windows OS you can grab the certificate from there. (I'm not too familiar with Windows but this solution worked for me because somehow windows acquired the correct certificate when I set it up on campus). But go to Certificate Manager in Windows OS and open the file labeled Trusted Root Certificate Authorities > Certificates. This might be specific for my school but export the USERTrust RSA Certificate.cer and load it into your ubuntu distro.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.