So I have and Asus R558UF notebook with an Elantech Touchpad. After installing Ubuntu 16.04, the touchpad worked once but after restarting, it failed to work and has not been working ever since.

This is output of xinput:

 ↳ Elan Touchpad                            id=12   [slave  pointer  (2)]

In Mouse and Touchpad settings, the touchpad is enabled. What should I do to fix this?

up vote 11 down vote accepted

I had the same problem. After googling a lot I found a workaround: in /etc/defaut/grub

sudo nano /etc/default/grub

I added i8042.reset to the line GRUB_CMDLINE_LINUX_DEFAULT

GRUB_CMDLINE_LINUX_DEFAULT="i8042.reset quiet splash"

and then

sudo update-grub

Finally after a restart the touchpad works fine (multitouch included).

  • 2
    Thanks a lot man, been struggling for weeks for a fix. Yours didn't work but when I searched the specific term 'i8042' got to know lots about this whole issue. I'll answer myself for others looking for a fix. – Paras Thakur May 10 '16 at 15:53
  • You might want to edit this to include a step where you make a backup of grub before changing it. It's a good idea to do this when changing important system files like this one. – Emily Apr 27 at 15:33

Okay so I found a fix for this issue.

Thanks to @Guillaume for pointing me to the right direction. This issue is very beautifully explained here on unix stackexchange.

It arises for some specific, rare devices such as mine (New Elantech Touchpad).

Sometimes touchpad would work and sometimes it wouldn't, it has got something to do with multiplexing.

To solve this issue I followed the answer by @Guillaume and added i8042.kbdreset=1 to the parameters in /etc/default/grub by following the exact same steps in the other answer.

i8042.reset didn't work for me.

  • Can confirm that this works, I am using a Gigabyte Aero 14v6 (2016) with an Elantech touchpad. – rkenmi Aug 14 '17 at 5:00
  • This worked for me too (with i8042.kdbreset=1), in combination with @geru's answer at kernel 4.17.4-041704-generic, on a Thinkpad P52 (2018). – irbanana Jul 5 at 18:21

I have the same touchpad on an ASUS laptop. Linux kernels below 4.5 don't have the drivers for this touchpad, so all you have to do is upgrade your kernel. Even though Linux kernels go all the way to 4.10 as of this writing, I like to trail the edge of technology, so if you just go to 4.5, you should be good.

You can find the latest kernels for Ubuntu at http://kernel.ubuntu.com/~kernel-ppa/mainline/

For example, to upgrade to 4.5.7, you would go to the ubuntu kernels link above and click into http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.5.7-yakkety/

Then, download the generic .deb packages. For 64-bit, these would be:

These will end up in your Downloads directory, so just open up a terminal there and type the following:

sudo dpkg -i lin*4.5.7*.deb

and follow up with rebuilding the grub bootloader

sudo update-grub

Then, reboot and select the new kernel and your touchpad should show up.

  • Or you couldupgrade your system to 16.10 :) – Zanna Mar 20 '17 at 5:28
  • This also helped me on my Samsung Ativ 9. I installed the most recent kernel v 4.12 and the touchpad is significantly more stable now. only after suspend I have problems, but I will figure this out likely. – n3rd Aug 17 '17 at 12:53

Edit 50-synaptics.conf file :

sudo nano /usr/share/X11/xorg.conf.d/50-synaptics.conf

Add the following lines:

MatchIsTouchpad "on"
Option "TapButton1" "1"

Like this:

Section "InputClass"
    Identifier "touchpad catchall"
    Driver "synaptics"
    MatchIsTouchpad "on"
    Option "TapButton1" "1"
    Option "VertEdgeScroll" "1"

Save , exit and reboot

protected by Community Oct 2 '16 at 15:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.