2

I just installed Ubuntu 16.04 via update from 14.04. I'm using gnome-shell 3.18.4. When I want to log to my gnome shell session the login is very slow, it takes more than 1 minute where the the only thing displayed is the wallpaper and then the gnome-shell session appears (the boot sequence works fine, although I don't see the Ubuntu Icon that should be displayed during this sequence after Grub, it is quick, the problem is after the login screen). Here are a few facts:

  • It works perfectly when login to Unity
  • After login to unity and ending the unity session it works perfectly when I login to the gnome session.
  • I removed all gnome extensions and this does not change the problem
  • I removed .gconf .local and .config and this does not change anything
  • Here is the .xsession-errors:

openConnection: connect: Aucun fichier ou dossier de ce type cannot connect to brltty at :0

  • I deleted .Xauthority and .ICEauthorithy but this did not solve the problem
  • I looked on the web but I have serious difficulties to understand what people say about this type of problem and what to do.

My computer is an HP EliteBook 840. Any help would be welcome, thanks !

1

Solved, this was a problem with alsa.

Here is what I did.

dmesg | less

gave me a message "error"

snd_hda_intel 0000:03:00.1: Disabling via vga_switcheroo

that I could locate to happen just before login thanks to the timing. I looked on this webpage: https://bbs.archlinux.org/viewtopic.php?pid=1460933#p1460933

I thus created a file

/etc/modprobe.d/my-alsa.conf

in which I put the only line

options snd-hda-intel enable=0,1,0

Now the problem has disappeared. That being said the sound via displayport does not work anymore but this is a minor annoyance.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.