After upgrading to Kubuntu 16.04 my JBL Flip 2 bluetooth speaker no longer works.

It connects just fine, and the sound is set to use A2DP sink with the speaker, but I get no sound.

I found some places claiming I had to change /etc/bluetooth/audio.conf, but that file no longer exists.

Does anyone know how I get it to work again?

  • Same issue with JBL Charge 2+ after upgrading from 14.04 to 16.04. Pairing is successful (the speaker beeps to confirm the connexion and Ubuntu shows the speaker as connected) but no sound is reproduced when requesting pulse to send audio to the BT device. Maybe an issue with Pulse as the vu-meter freezes when trying to send audio to the speaker and the port only contains "Speaker" when it included "Off", "High Fidelity Playback (A2DP)" and "Telephony Duplex (HSP/HFP)" before.
    – MaxAuray
    Commented Apr 27, 2016 at 7:20
  • Clues from syslog : /// pulseaudio[1942]: [pulseaudio] module-bluez5-device.c: Default profile not connected, selecting off profile /// bluetoothd[790]: /org/bluez/hci0/dev_0C_A6_94_EE_96_4E/fd0: fd(24) ready /// pulseaudio[1942]: [pulseaudio] bluez5-util.c: Transport TryAcquire() failed for transport /org/bluez/hci0/dev_0C_A6_94_EE_96_4E/fd0 (Operation Not Authorized) /// kernel: [ 842.519817] input: 0C:A6:94:EE:96:4E as /devices/virtual/input/input15
    – MaxAuray
    Commented Apr 27, 2016 at 7:27
  • 2
    I opened a bug for this bugs.launchpad.net/ubuntu/+source/indicator-sound/+bug/1577197 Commented May 1, 2016 at 16:30
  • Similar from 2014: askubuntu.com/q/481951/396228 Commented May 27, 2020 at 22:14
  • I just found this: help.ubuntu.com/community/SoundTroubleshootingProcedure -- first suggestion of killing pulseaudio, deleting some files, and restarting pulseaudio did the trick for me (Ubuntu 20.04, Sony XM3 headphones).
    – MrMas
    Commented Aug 30, 2021 at 16:41

3 Answers 3


I had the same problem after upgrading to 16.04. For me, there isn't a real fix, but I can get the speaker to work. I'm running Kubuntu so these steps are for KDE, and I'm not sure what the equivalent Unity steps are, but I'd imagine they're similar.

Here's what I did:

  1. Let the speaker connect.
  2. In your audio settings, change the profile to "Headset Head Unit (HSP/HFP)" or equivalententer image description here
  3. Power off Disconnect the speaker
  4. Restart the bluetooth service

    sudo service bluetooth restart

  5. Power the speaker back on and reconnect

  6. In your audio settings, change the profile back to "High Fidelity Playback (A2DP Sink)" or equivalent enter image description here

A2DP should now work. So far, it seems that things only go wrong when I try to connect in A2DP mode. Until there is a real fix/workaround, I am going to try to remember to always switch to HSP/HSF mode before powering off or disconnecting the speaker.


It's sufficient to connect, switch to HSP/HFP mode, disconnect, reconnect, and switch back to A2DP mode. There is no reason to restart the bluetooth service.

  • 2
    works for me..surprised though. Did you find a permanent fix?
    – hyades
    Commented May 6, 2016 at 7:08
  • 2
    No, unfortunately I haven't. I use bluetooth audio all the time (more than my built-in audio) so I'm hoping this gets fixed soon.
    – JaminSore
    Commented May 6, 2016 at 14:13
  • Such a fuss for a simple sound to come out of a mechanical thingle!! This was to let everyones' life easier...
    – Hamid
    Commented May 24, 2016 at 10:44
  • this is the only way I've found to correct it as well. That or repair, but that essentially does the same thing anyway.
    – DevDonkey
    Commented May 25, 2016 at 15:12
  • 1
    @pylover I'll give it a shot when I get a new speaker or fix my old one ... I'd prefer running a script to manually going through these steps every time.
    – JaminSore
    Commented Oct 10, 2016 at 3:53

After testing all workarounds, i wrote a python script to change profile, disconnect, reconnect and set profile to a2dp.

run it after pair/turning-on the device with python3.5.



$ python3.5 a2dp.py 
Connection MADE
Selecting device:
Device MAC: 00:22:37:3D:DB:1A
Device ID: bluez_card.00_22_37_3D_DB_1A
Sink: bluez_sink.00_22_37_3D_DB_1A
Turning off audio profile.
Disconnecting the device.
Connecting againt.
Setting A2DP profile
Device ID: bluez_card.00_22_37_3D_DB_1A
Updating default sink
Exiting bluetoothctl
  • 3
    Your script from Gist worked beautifully! Thanks! Commented Mar 11, 2017 at 16:24

I had the issue. For me worked to remove the bluetooth device and search for it again and reconnect.

  • This solved it for me . It stopped working when upgrading from 14.04 to 16.04. Commented Dec 23, 2016 at 22:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .