10

I upgraded from 14.04.x to 16.04 (64 bit) over the weekend. OMGubuntu! just had a post about how notes could be installed as a snap.

Ctrl+Alt+T and then

sudo snap install notes

then enter my password..

sudo: snap: command not found

What is up? What am I missing? I don't want to miss out on this new snap fun.

  • Whats the output of sudo updatedb && locate '*bin*/snap'? – heemayl Apr 27 '16 at 4:14
  • None, there is no output. – Dustin Apr 27 '16 at 4:26
19

The following worked on my system:

sudo apt-get install snapd
sudo snap install notes

I needed to log out and then back in for Dash to find 'Notes':

enter image description here

Note: There is currently some confusion with another Xenial package called snap which gives: 'location of genes from DNA sequence with hidden markov model'. If you get dpkg errors to do with this package when installing snapd (in particular overwriting of commonly named man pages) run the following:

sudo apt-get purge snapd

And then you should be right to go :)

The application 'Notes' was perhaps a little underwhelming, other packages look a little more promising:

andrew@athens:~$ snap find
Name                   Version                  Summary
audovia                3.2.2                    Database application for making music using JFugue MusicStrings
beagleblack            3.1                      OEM Beagle Bone Black
canonical-dragon       0.7.1                    The gadget snap for the dragonboard
canonical-i386         3.1.i386                 The gadget snap for generic i386 systems
canonical-pc           3.2                      AMD64 generic package
canonical-pc-linux     4.4.0-18+20160419.13-26  The ubuntu-core kernel snap
canonical-pi2          3.2                      Raspberry Pi 2 support package
go-example-webserver   16.04-4                  Minimal Golang webserver for snappy
hello-world            6.0                      Hello world example
http                   4.6692016                HTTPie in a snap
john-the-ripper        1.8.0-11765-g9a09113     John the Ripper Jumbo password cracker for Linux
links                  2.12-1                   Web browser running in text mode
moon-buggy             1.0.51.9                 Drive a car across the moon
morse-converter-py     1-2                      Simple command-line Morse converter
nmap                   7.12SVN-0.4              Nmap ("Network Mapper") is a free and open source utility for network discovery and security auditing
notes                  0.0.8~snap3.gita80fd1c   Note-taking application, write down your thoughts
shout                  0.53.0                   A self hosted web IRC client
sshtron                1.0                      multiplayer Tron via ssh
tmux                   2.3bump1                 tmux
tor-middle-relay       0.2.7.6-6                Essential infrastructure node for Tor network
ubuntu-calculator-app  2.1+snap3                Ubuntu Calculator application for the Unity 7 desktop
ubuntu-clock-app       3.6+snap3                Ubuntu Clock application for the Unity 7 desktop
ubuntu-core            16.04+20160419.20-55     The ubuntu-core OS snap
xkcd-webserver         16.04-5                  Show random XKCD compic via a build-in webserver
yacas                  1.4.2                    Yet Another Computer Algebra System

Interesting times ahead...

  • dpkg: error processing archive /var/cache/apt/archives/snapd_2.0.2_amd64.deb (--unpack): trying to overwrite '/usr/share/man/man1/snap.1.gz', which is also in package snap 2013-11-29-1ubuntu2 Processing triggers for man-db (2.7.5-1) ... Errors were encountered while processing: /var/cache/apt/archives/snapd_2.0.2_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1) – Dustin Apr 28 '16 at 4:19
  • 1
    That is a clash with some DNA software: packages.ubuntu.com/source/xenial/snap named 'snap' believe it or not. Looks like the man pages are named the same. Try sudo apt-get remove snap && sudo apt-get install snapd and you should be ok... – andrew.46 Apr 28 '16 at 4:47
  • Awesome it worked! Thank you. Should I accept your answer as is with our comments, or should your comment information be added to the answer before i accept it? – Dustin Apr 28 '16 at 5:28
  • 1
    I have added in some words about the package problems of snap and snapd. Probably should be also added as a bug report in Launchpad.... – andrew.46 Apr 28 '16 at 5:41
0

Installing snappy:

sudo apt install ubuntu-snappy-cli

Installing snaps:

sudo snap install <package>
  • I did try that but it caused dependency errors – Dustin Apr 28 '16 at 4:18
  • What dependency errors do you get? – JOnathanJOnes May 3 '16 at 15:32
  • ubuntu-snappy-cli is a dummy transitional package. – Chipaca May 16 '16 at 12:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.