10

I experience mouse lag although the graphic card is recognized by the os. (I already had it on 15.10 and upgraded to 16.04). The mouse lag is not firefox or browser dependent. Is there anything I can do about it, without doing a clean install of my ubuntu system?

nuc@nuc:~$ sudo lshw -c video
[sudo] password for nuc: 
  *-display               
       description: VGA compatible controller
       product: Haswell-ULT Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:45 memory:f7800000-f7bfffff memory:e0000000-efffffff ioport:f000(size=64)
  • Is it alltime lag or just after mouse inactivity (like 1second to react)? I get it just after the upgrade 15.10->16.04 – jaromrax May 4 '16 at 7:28
  • Alltime, but it seems away now. Maybe they did solve it through an update. – empedokles May 4 '16 at 9:31
  • Unfortunately my pleasure was premature. I experienced jittery motion again today. – empedokles May 4 '16 at 22:11
  • 1
    it was away for me also ... until ... today. After every 5-7sec idle it stalls for a second. However - unplug mouse/plug helped... – jaromrax May 11 '16 at 14:25
14

I found this solution! Credit goes to the original poster.

https://superuser.com/questions/528727/how-do-i-solve-periodic-mouse-lag-on-linux-mint-mate

To save some peeps the trouble of going to the link here are the specific instructions I followed (copy and paste each line on a terminal):

sudo su -
modprobe drm_kms_helper
echo N> /sys/module/drm_kms_helper/parameters/poll
echo "drm_kms_helper" >> /etc/modprobe.d/local.conf
echo 'drm_kms_helper' >> /etc/modules-load.d/local.conf
echo "options drm_kms_helper poll=N" >> /etc/modprobe.d/local.conf
| improve this answer | |
  • Man you just saved my life – Spock Mar 25 '19 at 6:56
  • I had to login just to upvote you and say THANKS MFER! This had been annoying me for too long. – sansa Nov 11 '19 at 2:03
  • ok wish I'd seen this earlier... +1 – Amos Folarin Mar 19 at 21:50
5

This might be irrelevant but I was also having my mouse pointer real slow all of sudden in properly working ubuntu 18.04.Googled like crazy for about an hour, tried restarting for few times, checked RAM and CPU usage it was not even half, try unplugging the mouse for couple of times, went through the mouse settings, tried above commands did not work and finally found out the zoom was switched on. Switched it off and worked like a charm.

The option can be found in settings > universal access.

enter image description here

| improve this answer | |
  • I searched for several hours and this is the only thing that worked for me on Kubuntu, thanks! – homebrand Jun 9 '19 at 22:29
  • @homebrand where is that option on kubuntu? – NIZ Jul 17 '19 at 12:28
  • @NIZ under System Settings > Desktop Events > Accessibility section – homebrand Jul 20 '19 at 0:01
0

One thing worth checking is whether the the mouse is connected to a USB hub that has other devices connected. In my case, my Bluetooth mouse shares a USB hub with an Ethernet adapter.

The solution was to simply move the mouse to a different USB port.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.