1

I would like to open by default all .txt files with emacs, but when I right-click on the file, and go to properties, and then go to the "Open With" tab, emacs doesn't appear.

It is not listed either in "recommended applications" or under "other applications". This may be because I installed emacs from source.

Please how can I always open a file with an application that doesn't appear in that list?

1

If you have (server-start) in your ~/.emacs init file, you can select gnuclient in Properties->Open With like this

Thus, you're not constantly starting and stopping emacs.

| improve this answer | |
  • I have added (server-start) to ~/.emacs and still it doesn't appear gnuclient. I don't know if it's related with the fact that I installed emacs from source – DieDauphin Apr 27 '16 at 20:10
  • Maybe. Tell emacs $x server-start, then bash sudo lsof -cemacs and look for a "socket". – waltinator Apr 27 '16 at 20:46
  • do I add emacs $x server-start to ~/.emacs?. I don't understand what do you mean by "socket" – DieDauphin Apr 27 '16 at 21:01
0

I think that if the application does not appear in that list then it is because it is not installed in your pc. So I suggest you instead right click on the file, select "Open with other Application.." > "Find applications online". When it installs then you can now select just as the path you took, and set it as default... Hope that helps you.

| improve this answer | |
  • Yes, I installed emacs from source – DieDauphin Apr 27 '16 at 20:11
0

When you are in the "properties" section see if GNU Emacs 24 (GUI) is listed in the recommended applications section. If it is, you should be able to on it just once, and then proceed with the option to set it as the default application to .txt files with.

If GNU Emacs 24 (GUI) is not listed in the recommended applications sections, then simply scroll down the "other applications" section until you run into it. From there you should be able to have the option to set it as your default application.

| improve this answer | |
  • Yes, but the problem is that is not listed neither in "recommended aplications" nor in "other applications" – DieDauphin Apr 27 '16 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.