42

Have you guys used Acestreams? The repository has not yet issued for 16.04 LTS, but besides, it might not be free anymore.

Is anyone watching Acestreams/Sopcast with any other software + where can I find such software?

Thank you!

  • I'll try, but in 16.04 the trusty repository doesn't work :( – Mookey Apr 30 '16 at 11:08
  • 1
    Have you tried this? This still requires acestream-engine, but you can then play the streams in any external player (e.g. VLC, mpv). github.com/jonian/acestream-launcher – pileofrocks Jun 14 '17 at 17:56
43

It's now one step installation:

sudo snap install acestreamplayer

and to run it:

acestreamplayer.engine --client-console
acestreamplayer

If running the above commands after the successful snap installation fails with a command not found error, you might need to add /snap/bin to your $PATH or run it using the following commands:

snap run acestreamplayer.engine --client-console
snap run acestreamplayer

Based on info @ https://www.cnx-software.com/2018/04/15/how-to-install-and-use-acestream-easily-in-ubuntu-mint-linux/

| improve this answer | |
  • 2
    Works on 18.04 LTS. – Mookey May 7 '18 at 5:35
  • 3
    After running the first command to install, I just opened Ace Player HD from the menu, which started it up in the background. After that I clicked on an acestream:// link and it opened automatically in VLC. – bmaupin Jun 16 '18 at 13:28
  • Sadly this is only version 2 of ace stream player. – Jamie Hutber Aug 11 '19 at 13:16
25

It works for me. Install only acestream-engine.

  1. Install acestream-engine

    echo 'deb http://repo.acestream.org/ubuntu/ trusty main' | sudo tee /etc/apt/sources.list.d/acestream.list
    sudo wget -O - http://repo.acestream.org/keys/acestream.public.key | sudo apt-key add -
    sudo apt-get update
    sudo apt-get install acestream-engine
    
  2. Install Kodi (XBMC)

    sudo add-apt-repository ppa:team-xbmc/ppa
    sudo apt-get update
    sudo apt-get install kodi kodi-pvr-iptvsimple kodi-audioencoder-*
    
  3. Install addon p2p-streams for Kodi (video)

    https://superrepo.org/get-started/

  4. Start acestreamengine no root

    acestreamengine --client-console
    

    or

    acestreamengine --client-gtk
    
  5. Start Kodi

    Video - addons - p2p-streams - Addon Website-parsere

It is the only way.

| improve this answer | |
  • 1
    OK, that was my mistake. I'll give it a go, thanks! – Mookey Apr 30 '16 at 12:25
  • 4
    So I got it to work, although KODI seems to be freezing on its own will. Acestream engine is running as you said, and I can play the Addon Website Parsers, i.e. programs listed there. Any way of adding a new programme? I cannot copy/paste the acestream code into the "play from acestream link" as CTRL+V doesn't work. I'm mostly interested in English premierleague football. – Mookey Apr 30 '16 at 21:47
  • 2
    CTRL+C / V never works, yes. I haven't been able to find the solution, but there are Add-Ons which have the program you search for, rather than the need to copy past stream links. As for the freezing, I upgraded to kernel 4.6 where it hasn't happened yet. Also, I use a second monitor for it now. – Mookey May 30 '16 at 10:11
  • 5
    It does not work anymore! Cannot install p2p-stream. – user308164 Jan 15 '17 at 15:47
  • 2
    You need to update your answer, as it stands it is not functional. – Luís de Sousa May 12 '18 at 18:31
15

I got this option running in Ubuntu 16.04 LTS: https://github.com/jonian/acestream-launcher

Instructions:

1.Prerequisites: If you are unsure that you have all the dependencies, run:

sudo apt-get update
sudo apt-get install python python-psutil python-pexpect python-notify2 acestream-engine vlc

2.Clone the repository:

git clone https://github.com/jonian/acestream-launcher.git

3.Run install.sh script as root:

sudo bash ./install.sh

Now, once you have the URL of the streaming, run:

acestream-launcher URL

For example:

acestream-launcher acestream://edca97797b5749855c9c0d512312312312323

Enjoy.

| improve this answer | |
  • 5
    This is a nice lightweight solution! Don't forget to add the repository as in the first step of askubuntu.com/a/765407/14747 ! – krumpelstiltskin Sep 30 '17 at 13:27
  • 2
    I'm getting the following error on Ubuntu 14.04: Traceback (most recent call last): File "/usr/bin/acestream-launcher", line 161, in <module> main() File "/usr/bin/acestream-launcher", line 151, in main AcestreamLauncher() File "/usr/bin/acestream-launcher", line 44, in init self.start_acestream() File "/usr/bin/acestream-launcher", line 70, in start_acestream if 'acestreamengine' in process.name(): TypeError: 'str' object is not callable – andrestoga Jan 3 '18 at 23:03
  • 1
    E: Unable to locate package acestream-engine ubuntu v18 – Jamie Hutber Aug 11 '19 at 13:19
  • 1
    There is no ./install.sh inside this repo :( – Jamie Hutber Aug 11 '19 at 14:07
7

The easiest way: Snap (I used it without problems in Ubuntu Mate 16.04 and now in Mate 18.04 beta).

To install just enter the following into the terminal:

sudo snap install acestreamplayer

To run for the first time, it is recommended to use the terminal:

snap run acestreamplayer

(without sudo)

The first configuration takes some time, it seems to block, but when it is finished, the player and the server icon will appear. And also the two shortcuts (server and player) are created in the Sound&Video Menu

Cheers

| improve this answer | |
  • Worked for me on Ubuntu 18.04 (unlike the acestream-launcher ones above). – Waldir Leoncio Apr 29 '18 at 12:03
4

Found that it has been packaged here:

https://snapcraft.io/acestreamplayer

Working fine for me.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.