0

I followed this speed tutorial: https://www.liberiangeek.net/2015/11/how-to-easily-install-wordpress-on-ubuntu-15-10/ but I got stuck at Step 4...

When I run following code in the terminal:

sudo apt-get install php5 libapache2-mod-php5 php5-mysql php5-curl php5-gd php5-intl php-pear php5-imagick php5-imap php5-mcrypt php5-memcache php5-ming php5-ps php5-pspell php5-recode php5-sqlite php5-tidy php5-xmlrpc php5-xsl

I get following error messages from all packages:

Package "name_of_package" is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package 'name_of_package' has no installation candidate

... .. . What should I do? What source should I use and how do I add them?

Thanks!

0

Ubuntu 16.04 removed php5 packages and removed those with PHP 7.0 packages that doesn't have php5, but just php inside package names, so replace your command with:

sudo apt-get install php libapache2-mod-php php-mysql php-curl php-gd php-intl php-pear php-imagick php-imap php-mcrypt php-memcache php-ming php-ps php-pspell php-recode php-sqlite php-tidy php-xmlrpc php-xsl

Similar question here: PHP and Apache2 broken after upgrade to Ubuntu 16.04 or PHP rendered as text after Ubuntu 16.04 upgrade

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.