2

I have a remote machine I need to ssh to using blowfish encryption. I set everything up on my laptop on my previous distro and I have in my config file setup for blowfish. Today I install Ubuntu Gnome and when I try to ssh to whatever machine I get an error

/home/yotam/.ssh/config line 43: Bad cipher 'blowfish'.

I searched what I need to install, but it seems that this should come with the distro. What am I missing?

4

There is no cipher called blowfish in SSHv2. It was only in the old protocol SSHv1, which is gone (hopefully also on Ubuntu).

SSHv2 has cipher called blowfish-cbc as pointed out in manual page for ssh_config (always good place to start).

0

In ubuntu 16.04 you can try this (replace user and ip)

ssh -XC -c aes128-gcm@openssh.com youruser@1.1.1.1
0

All you need to do is delete any lines containing:

cipher blowfish

from the ~/.ssh/config file, which in the case of the original poster is line 43, as indicated by the error message. However, this error message is misleading; see the answer on https://bugzilla.redhat.com/show_bug.cgi?id=1281705

The probable cause is that you set up your SSH connection some time ago, or used an old tutorial, and now you upgraded to a version of SSH that doesn't permit this option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.