4

This question already has an answer here:

My OS is Ubuntu 16.04. I downloaded Eclipse Version: Mars.2 Release (4.5.2) and I had a problem with the main menu not showing.
I solved it by running Eclipse with UBUNTU_MENUPROXY=0 and the menu is visible but now I have another problem. Some of the options in the menu don't work.
For example the Window->Preferences only shows the General page and I can't select any other option.

Image of the broken menu

Is there a solution for this problem?

marked as duplicate by Community Apr 29 '16 at 8:05

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Your UBUNTU_MENUPROXY=0 tip fixed my problem! I added env UBUNTU_MENUPROXY=0 /.../eclipse to my shortcut. – Alfonso Nishikawa Jul 5 '18 at 0:17
10

Try to start Eclipse after editing your eclipse.ini file and tweaking the launcher entry like this:

--launcher.GTK_version
2

Example file:

-startup
plugins/org.eclipse.equinox.launcher_1.3.100.v20150511-1540.jar
--launcher.GTK_version
2
-product
org.eclipse.epp.package.cpp.product
--launcher.defaultAction
openFile
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
--launcher.appendVmargs
-vmargs
-Dosgi.requiredJavaVersion=1.7
-XX:MaxPermSize=256m
-Xms256m
-Xmx1024m

See: https://stackoverflow.com/questions/36822242/eclipse-doesnt-work-with-ubuntu-16-04/36859485

  • 1
    This answer in your link worked for me. stackoverflow.com/a/36825434/193708. Thanks – Niroshan Aug 15 '16 at 6:47
  • This didn't work for me. It actually made the problem even worse. – Astrum Oct 5 '16 at 5:36
  • Worked with Eclipse Neon.2 for J2EE on Xubuntu 16.04. – sharky Dec 30 '16 at 10:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.