6

lsusb does see the device. Sierra EM7455

Tried to add a new mobile broadband connection.

Under all connections "mobile broadband not enabled" grayed out

Any help would be appreciated

  • did you find a solution? I have the same exact problem – allanlaal Sep 6 '16 at 20:47
  • Sierra isn't the name of OS like OSX but instead of the mobile broadband yes? – William Jan 19 '17 at 1:43
3

I managed to get the Sierra EM7455 working on my Thinkpad X1 4th gen. I did try a few things before it worked, so hopefully the below description is complete.

I upgraded the modemmanager package to the one from Ubuntu 16.10 by downloading the .deb package and then installing it using the dpkg -i command. Apparently the Sierra EM7455 expects some “FCC auth” command at startup which is implemented in modemmanager 1.6.0

The modemmanager package has some dependencies but I just downloaded and installed these as well:

libmbim-glib4_1.14.0-1_amd64.deb
libmbim-proxy_1.14.0-1_amd64.deb
libmm-glib0_1.6.0-1_amd64.deb
libqmi-glib5_1.6.0-1_amd64.deb
modemmanager_1.6.0-1_amd64.deb

I also upgraded to the 4.7.2 kernel. I am unsure if this is actually necessary or if the current default kernel for 16.04 has been patched.

It took me the better part of two evenings to make it work, so hopefully this can help you as well.

  • I'm able to get the modem to say "connected" but it doesn't receive an IP address. I have the version of packages that you have. – Jonathan Jan 16 '17 at 21:57
  • Sorry for your trouble. After having used the above configuration for a short while it turned out to be unstable. I have reverted to using an external modem until I find a better solution. – Kjeld Jan 18 '17 at 11:14
  • 1
    Man, after 6 days of struggle.. i was in deep depressions, it was tearing up my family and relationships, finally, your solution worked for me. I cannot thank you enough I send many good Karma points to you. – Marián Zeke Šedaj May 25 '17 at 20:11
1

After doing what @zanna describes, you still need to do the following for network manager to get an IP address.

  1. in terminal sudo rfkill unblock wwan
  2. enable broadband in network manager (you need to do this because it sends the magic packet to bring the EM7455 out of low-power state)
  3. watch syslog - after a few seconds it will fail.
  4. in terminal sudo mbim-network /dev/cdc-wdm1 start
  5. watch syslog, it will succeed, but you won't have an IP address.
  6. in terminal sudo mbim-network /dev/cdc-wdm1 stop
  7. enable broadband in network manager
  8. and it works!

note your modem might be /dev/cdc-wdm0 or some other integer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.