12

The Font Manager application fails to initialize in Ubuntu 16.04.

When I run Font Manager it starts to initialize saying "Querying installed files..." but quickly hangs. An Exit needs to use the Force Quit and then I get the "Not responding" message. So there is something wrong with this version of Font Manager or its integrating with Ubuntu 16.04.

I run 64-bit version of Ubuntu.

How could that be fixed?

  • Try to run font-manager from a terminal. Please paste any relevant lines into your question. – Jos Apr 26 '16 at 11:58
  • No, the command is font-manager. – Jos Apr 26 '16 at 13:07
  • I just tried the comand <font-manager> and the problem remains, it must be related to the upgrade to 16.04 – Fellipe Cotrim Apr 26 '16 at 13:16
  • But what do you see in the terminal? – Jos Apr 26 '16 at 13:17
  • INFO : Verified /home/fellipe/.fonts.conf INFO : Font Manager is now starting – Fellipe Cotrim Apr 26 '16 at 13:19
17

this worked for me (ubuntu 16.04 upgrading from 15.10)

installed font manager from: http://fontmanager.github.io/

then, in the terminal:

sudo add-apt-repository ppa:font-manager/staging
sudo apt-get update
sudo apt-get install font-manager

and downloaded font from fonts.google.com and extracted, then opened each font with right click -> font manager

confirmed 'install'

  • +1 works like a charm now and looks much better than the old one – philipp Jun 30 '16 at 15:13
  • What to do with the old one? – Fleuv Aug 25 '16 at 20:37
  • 1
    @Fleuv: If you install the PPA version, the old version will be uninstalled automatically. – Gunnar Hjalmarsson Aug 26 '16 at 1:07
  • i did this but also had to start the font-manager with sudo from the terminal to get new fonts installed. – Riscie Aug 31 '18 at 6:41
3

The Ubuntu and Debian archives include an ancient version of font-manager (0.5.7-4). One of the news in Ubuntu 16.04 was a new package for providing Chinese fonts, fonts-noto-cjk, and font-manager 0.5.7-4 can't handle fonts-noto-cjk (see this Debian bug report).

So if you don't need Chinese fonts, an alternative workaround is to uninstall the fonts-noto-cjk package. (Upgrading via ppa:font-manager/staging, as suggested by gzb, will work without uninstalling anything.)

There is a related Ubuntu bug.

2

I had the same experience as you. I found the solution: use PPA to install a newer version of Font Manager

https://launchpad.net/~font-manager/+archive/ubuntu/staging

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.