4

I would like to connect to Freenode with irssi using both SSL and SASL. Instructions for using the script cap_sasl.pl that worked for older versions of irssi now show the following error under Xenial Xerus:

19:34 -!- Irssi: Error in script cap_sasl:
19:34 cap_sasl has been unloaded from Irssi 20160323.0008 because it conflicts 
          with the built-in SASL support. See /help network for configuring 
          SASL or read the ChangeLog for more information. at (eval 9) line 52.

How can I fix this?

6

Xenial Xerus now has a newer version of irssi:

andrew@athens:~$ irssi --version
irssi 0.8.19 (20160323 0008)

This version has built-in support for SASL and has been set to reject the cap_sasl.pl script with the error message in the question. Easy enough to fix by closing irssi and removing the script and links to it:

mv -v $HOME/.irssi/scripts/cap_sasl.pl $HOME/.irssi/scripts/cap_sasl.pl_bak    
rm -v $HOME/.irssi/scripts/autorun/cap_sasl.pl

Then set yourself up with Freenode using both SSL and the built-in SASL with these commands from within irssi. First remove any mention of Freenode and the 'conventional' port (this comes preconfigured with a fresh installation of Ubuntu and irssi):

/SERVER REMOVE chat.freenode.net 6667 Freenode
/NETWORK REMOVE Freenode

Then add an autoconnect to Freenode with the SSL settings and appropriate SSL port:

/SERVER ADD -auto -ssl -ssl_verify -ssl_capath /etc/ssl/certs -network Freenode irc.freenode.net 6697

Now add the SASL settings, making the appropriate changes for your username and password (and omitting the brackets of course):

/NETWORK ADD -sasl_mechanism plain -sasl_username <username> -sasl_password <password> Freenode

When this is done issue the following commands from within irssi:

/save
/exit

And when you restart irssi you should see the following 2 messages flashing by:

  1. 20:31 -!- SASL authentication succeeded = successful SASL authentication
  2. 20:31 -!- Mode change [+Zi] for user andrew = successful SSL connection

Now type in /join #ubuntu and you are in the thick of it :)

References:

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.